Updating Firmware on S500

We using several S500s and we noticed the phones have not been updating their firmware over time.

Currently we are using firmware (Boot is and tried updating to using TFTP and the EPM but every time we reboot the phone it does not pull down the new firmware.

I also tried uploading the firmware manually (WinSCP into the PBX /tftpboot/sangoma/1) pulled off the S500.rom file and tried uploading that but I would receive an error “Upgrade Fail ! Please check the firmware file !” I downloaded the firmwares from the WIKI and tried this manual process for,, and and all of them had the same error.

What is the best solution to get this to work? Also is there any checks in the EPM that helps us track the phone’s current firmware so we can spot check to make sure they are updating?

any update on this? im facing the same issue on a later version, have 8 phones i simply cannot update the firmware on

In my experience, which might or might not apply to your particular situation, if you reset the phone to factory defaults, it will check for firmware on reboot and should update it automatically, at least that’s how it works for me. I really can’t understand why they would be factory configured for auto-update, but that is just my opinion.

please open a support ticket on the matter - we’d like to have a look

What I ended up doing was using the endpoint manager and connect via http. It appears the TFTP no longer allows us to upload the firmware.

I stopped trying to use the web gui to update the firmware.