Updating Connected Number Display Cisco 7942G


Been working through this slowly, and thought a post here might get this solved quickly.

We have some 7942G on SIP firmware 9.4.2 that I am migrating from UCM to Asterisk/FreePBX … it’s Asterisk 11 + FPBX 2.11.

My problem is that when we transfer calls, the connected number display does not update with the new call details. I.E. if party A is on a call from party B, and transfers party B to party C, party C only see party A’s CID and never sees party B’s CID on their display - the result is that no one really know when a transfer happens, so there’s the whole “Hello?” after a few minutes of silence…

I’ve been playing around with canreinvite (yes and no) sendrpid (remote-party-id and p-asserted-identity), and trustrpid is set to Yes in the extension settings. On the phone config i have (i think) enabled it with;


I have had no luck with getting it to work with the above. I’m thinking it must be something else in the phone config, or maybe I am just getting the combination of settings wrong.

Appreciate any help with this one …

As I progress … I connected up some 7940G’s with SIP v8.6 firmware. I enabled sending remote-party-id, and that’s it and the connected line display updates when a xfer completes. I didn’t test it without enabling this setting, however I also like that this setting enables you to see CIDNAME etc when you dial someone.

So it happens only on the 7942G’s … must be a configuration issue. From what I can determine this should work on the 7942G SIP v9.4 firmware…

I since downgraded my phone to 8.4(5) and the Connected Number Display now updates. Must be a lack of support in the 9.4 SIP firmware …

Hi zirophyz,

I’m trying to enable this function on a 7941G. What settings did you finally use to get this working? I am using firmware 8.5.4 and freepbx 12. I was not able to find the 8.4.5 verison.

Hi Jack,

As in the original post I would make sure that remotepartyID is set to true, and in your extension configuration I would also check that it’s sending RPID and trustrpid is set to true.

Other than that it seemed to just work, and I have a feeling that even the above settings didn’t make a difference. If you get stuck with firmware, make a Cisco account, pretty sure that the old firmware for the 7940 and 7941’s aren’t locked to a SmartNet contract.