FreePBX | Register | Issues | Wiki | Portal | Support

Update yealink firmware in EPM please


(Bob Reiber) #1

Specifically for the t42s but I’ve noticed that at least a few other models have outdated firmware as well. I bought a couple of t42s phones with the hope of getting them on the wifi at a customer that has no structured wiring. What I’ve learned so far is this for the t42s model:

-The latest level in EPM (labeled 1.17) 66.81.0.70 does not support wifi
-The level that came loaded on the phone i just bought 66.82.0.30 does work
-I was told on the Yealink forum that everything as of 66.83.0.10 does work for the t42s but as pointed out above this isn’t quite accurate.
-The latest level on the Yealink site is 66.83.0.50

http://support.yealink.com/documentFront/forwardToDocumentDetailPage?documentId=145

And yes, I added the entry to the basefile to activate it since our basefile doesn’t have a number of the parameters.

image

per the yealink instructions

obligatory:
PBX Firmware: 12.7.5-1807-1.sng7
FreePBX 14.0.3.13
EndPoint Manager 14.0.2.144


(Bob Reiber) #2

Also, I know I can add my own .rom files to the tftpboot folder but it would be nice to have the paid EPM updated. Thanks.


(Avayax) #3

Beware of yealink V83 firmware if you are using openvpn to connect the phone to a VPN server.
That’s broken.
There is also another BLF issue that’s been discussed in this forum.


(Bob Reiber) #4

Do you have a link to these discussions? On the v82 firmware that my t42s is currently running the BLFs seem to work just fine but I haven’t tried the VPN.


(Avayax) #5

The OpenVPN issue has a few Yealink forum threads with no response and I have opened a ticket on it which is being worked on (hopefully).