Update broke Aastra XML

Was running and system updated itself to and since the Aastra XML seems to be broken.

Have since updated to - still in same state.

Press a button on the phone and phone says “The application cannot connect to Asterisk Manager”

CLI says

[2013-08-07 14:27:40] NOTICE[10473]: manager.c:2618 authenticate: failed to authenticate as 'aastra-xml' [2013-08-07 14:27:40] NOTICE[10474]: manager.c:2581 authenticate: tried to authenticate with nonexistent user 'aastra-xml'

My custom .prf file is still in place

Had to add my custom extensions back into the /var/www/html/aastra/config/asterisk.conf - looked like it put it back to stock.

Tried to run apply_prf and replied cannot connect to asterisk manager.

Looked at the .cfg file for that phone and the proper IP address is in there to connect to for the xml scripts

dd back the stanza for aastra-xml in your /etc/asterisk/manager*.conf suggest you use manager_custom.conf

Thanks for the reply Dicko, but I dont really know what you mean there. dd back the stanza??

Do you know if this is something they changed in the updates?

flavor to taste

oops, can’t edit

dd = add , the stanza

secret = aastra227872
displayconnects = no
read = system,call,log,verbose,command,agent,user,originate
write = system,call,log,verbose,command,agent,user,originate

flavor to taste.

dd is also a UNIX command. I was like…What is he saying? :wink:

Tried adding the stanza into manager_custom.conf but that didnt do it - I uncommented the include in manager.conf & didnt help

Added it into manager.conf and now its working again.

Thanks for your help!