Unsupported transport (PJSIP_EUNSUPTRANSPORT)' sending OPTIONS request to endpoint

Hi, keep seeing in CLI

Unsupported transport (PJSIP_EUNSUPTRANSPORT)’ sending OPTIONS request to endpoint

all PJSIP extensions are unavailable.

Have seen another post regarding this were it was said to make sure
Allow Transports Reload is set to No. This FreePBX 14 PBX running Asterisk 16.6.2 does have Allow Transports Reload set No.

Sip Settings PJSIP has: udp - - All YES and tls - - All YES

While writing this, ran # asterisk-version-switch and selected 1 for Asterisk 13 to see if the messages in CLI stopped. All PJSIP extensions are online after Asterisk version became 13.29.2.

So far ~ 10 minutes later the PJSIP error messages have not reappeared.

Is this issue just applicable to Asterisk 16?

Is it possible that “Allow Transports Reload” was previously set to “yes” and was then set to “no”, but without restarting Asterisk?

Otherwise I’m not aware of any other problems, unless TCP or TLS is in use and the connections themselves went down for some reason.

Hi Jcolp, highly doubt “Allow Transports Reload” was ever set to yes. So now it’s unclear if the downgrade of Asterisk to 13 fixed it or just the fact the asterisk was in a sense restarted fixed it.

Would you suggest # asterisk-version-switch to 16 again and if the issue reoccurs run # fwconsole restart ?

Restarting Asterisk will resolve the problem. There’s no changes between 13 and 16 in that area. When it does happen please provide the actual console output, as well as information on whether you are using UDP/TLS/TCP for the endpoints in question. The output of “pjsip show transports” would also be good.

Will run # asterisk-version-switch now and see if the errors come back. There are a few extensions using TLS because they are mobile. The rest just use plain udp because they connect to FreePBX server via VPN.

Thanks Joshua.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.