Unrecognized option --webroot

I’m trying to install FreePBX 2.4.0 with Asterisk 1.4.18 but the FreePBX installation fails with:

Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Console_Getopt: unrecognized option --webroot

I wish to install the web files of FreePBX in /var/www/asterisk, so I started install_amp with the following command:

./install_amp --username asterisk --password [mysqlpassword] --webroot /var/www/asterisk

What’s wrong?

Thank you very much!

I’ve run into this problem myself.

The very first time you run ./install_amp
it will prompt for values for your webroot.

If you try to run ./install_amp again to over-ride the value you set the first time, you’re out of luck. You need login to mysql with your username / password, drop the asterisk database, and run ./install_amp again.

was having the same problem. the install scripts REQUIRE the webroot be /var/www/html even though their appear to be options to change it, they are ignored.

tried dropping the db a few times, but it kept resetting webroot to /var/www/html. so this finally worked for me:

  1. run ./install_amp which puts a record in ‘freepbx_settings’ table with keywork ‘AMPWEBROOT’.
  2. change the value of the row with the keyword AMPWEBROOT to ‘/new/html/directory’.
  3. run ./install_amp again…

only then did everything start working for me in another directory than the one that was hardcoded in the install.