FreePBX | Register | Issues | Wiki | Portal | Support

Unreachable Extension Problem

siptrunk
freepbx
configuration
bug
Tags: #<Tag:0x00007fcd1f058388> #<Tag:0x00007fcd1f058248> #<Tag:0x00007fcd1f058108> #<Tag:0x00007fcd1f059e68>

(Kuipumu) #1

Hi, I have been fighting various days with this problem without finding the cause of the problem, I work in a company where they a have a FreePBX setup in Vultr, I have almost no knowledge with PBX server before, only a lot of experience with Linux, routers, switches, and many other network configuration related experience. There is around 11 extensions connected to the PBX server, but for the last weeks there has been a lot of problems to configure new extensions on remote workers to the network, In some cases it just connects fine, but in some other cases, the SIP client connects without any problem to the PBX server after adding the current IP of the user to a whitelist, but, even through the SIP gets connected, no other extension can call to that extension, they can call back, but even if they do sometimes we can’t hear anything, sometimes we can reach their extension and hear everything fine.

I’ve checked the status of the extension by running the command “sip show peers” on the CLI, and all I see it’s that, for that extension, there is the IP of that client, but the status shows has unreachable, Just like this:

Name/username      Host                   Dyn Forcerport Comedia    ACL Port     Status
401/401                    xxx.xxx.xxx.xxx  D    Yes            Yes            A      24162  UNREACHABLE

I also checked the logs everytime I try to make a call to that extension and just get a “No response” from that extension and this is what I got:

https://ghostbin.com/paste/u4o6h

I also tried to check the router settings on that client, he has a TP Link TL-WR841ND, I disabled the firewall on the router, but still, could not reach. He is using Grandstream Wave (GS Wave) has a SIP client to connect, I’ve tested the same extension on my phone with the same software and it could reach to the server and make calls and receive them, what could be causing this issue with this client network?, we also got the same problem with another person using a different extension, but in this case I did not had a router or firewall and still got the same result, do somebody has experienced this issue before and have an idea on what I could check and test to fix the issue?, if anyone could help me I would be really appreciated, Thanks.


(Tom Ray) #2

That is 100% a NAT issue at the location with the phone. The firewall just allows/disallows things in, NAT is what makes it go to the local address. The router could be having a NAT issue or a config change is needed. Make sure anything like SIP ALG, SIP Helpers, Port Randomizers are turned off.


(Kuipumu) #3

Yes I read about being a NAT issue, but I disabled the firewall in the computer at the phone location, should I need to forward a port on that location on the router?, with “SIP ALG, SIP Helpers, Port Randomizers” you mean turning those options off in the FreePBX server?, thank you very much


(Kuipumu) #4

I disabled al SIP ALG and SIP Helpers, Port Randomizers in Xlite and GS Wave, I opened the 5060 port, I also set a static IP for the computers and set that IP into DMZ in the router, and I’m still getting some extensions disconnected randomly, they are connected and then randomly drop, and if they restart Xlite or GS Wave they get connected back again, when the go down they show their status as UNKNOWN status and a (Unspecified) IP, or just an Unreachable status, what could it be?, can someone help me?, I have no other idea in what could be making these problems.


#5

Give up on GS Wave. If this is a job involving field work such that a mobile app is required, please provide some details.

Turn off the DMZ. In X-Lite, Advanced settings for the account, set ‘Reregister every’ to 120 seconds and check the Send SIP keep-alives box. Make sure that the computer is set to never sleep. If you still have trouble, post details about the setup (OS, computer model, etc.)


(Kuipumu) #6

Thank you very much Stewart, we don’t really have a work in which we really need a mobile app, but, some of our people like to be able to connect through the mobile phone, either because they lack a computer in a certain moment or they lack a microphone in the computer, it’s really not needed since that is not the case, but if you know a good alternative to GS Wave i will be really glad to know, I had used Zoiper also on mobile, but have not tested long enough to see if its better.

I set 3600 to “reregister every” option in Xlite, will set it to 120, the “minimum time” it’s set to 20, the SIP keep-alives box is checked, and I also uncheck the “use rport” option so it uses the standard 5060 port, and also forwarded that port just to test (I know is insecure to use that default port and leave it open). One thing is that I’m not sure what is the amount I need to put in “poll time” and “refresh interval”, right now “poll time” it’s on 300 value and “refresh interval” it’s set to 60, The two computers in which I’m testing don’t go to sleep, I they go to blank screen only, one of them is Windows 7 and the other one is Windows 10, I will check if maybe Windows is turning off the PCI ethernet port or Wifi adapter to reduce energy consumption, the Windows 10 computer is a laptop and the other is a desktop computer with Windows 7, the desktop computer is connected through ethernet port to a TP Link TL-WR841ND router and the other one is connected through Wifi to a router Airtel Alcatel MW40 that connects to the internet from mobile 4g cell phone network.

Sorry for the delay, if you can provide me any idea on what is causing the problem I will really appreciate it, Thank you and have a great day.


#7

In X-Lite, if the short refresh interval doesn’t help, check whether the public IP of the remote extension has changed. If not, try running a continuous ping from the PC to the VoIP server to check whether connectivity is somehow intermittent. If that’s also ok, look at the Asterisk log for a pattern of when the phone becomes unreachable and when it becomes reachable again.

In most situations, my first choice for a fixed remote extension would be an inexpensive hardphone such as https://www.amazon.com/Grandstream-GXP1625-Medium-Business-Device/dp/B00VNMWRFK/ (if BLF would be useful, look at GXP1628). The Amazon link is just an example; you can likely find better pricing elsewhere. If that’s beyond your budget, used IP phones can be found e.g. on eBay for almost nothing, but do your homework first – some such as Cisco are difficult to configure for FreePBX.

Next choice would be a softphone with a decent headset. Most newer computers have a 4-conductor 3.5 mm jack that is compatible with wired mobile phone headsets. Older machines (with red and green jacks) require a ‘computer’ or ‘Skype’ headset, or get an appropriate adapter. Bluetooth is also an option, especially if you have an existing headset to pair with the PC. If it’s an older machine without built-in Bluetooth, get a cheap adapter such as https://www.amazon.com/Bluetooth-Receiver-Transfer-Wireless-Keyboard/dp/B0775YF36R/ . If buying a new headset, get one with a long boom so the mic is near the user’s mouth. That allows the gain to be turned down, greatly reducing background noise heard by the remote party.

If you must use a mobile app, Groundwire (not a free app) works very well for me, using push notifications. However, I’m aware that the app has many negative reviews (mostly for older versions). If you buy it, test it immediately – if you discover a serious issue within two hours, just tap the Refund button when you uninstall. If it takes you longer to see a major problem (but less than 48 hours), you can likely get a refund at https://support.google.com/googleplay/answer/7205930 .