Unprovisioned but getting settings

Alright I need the help of one of you guys that knows his stuff :slight_smile: Here’s the rundown. I was having some problems with an old trixbox install so I decided to start from scratch and install the FreePBX Distro. I got everything done and restarted the phones with factory reset (don’t save network settings) and the phones are working but I’m having some issues. I changed the logo to the penguin (it was a wolf head since our company is called Wolfes) so that I would know it was picking up the new settings when I saw the penguin. My phone and a couple others have the penguin but most of the other 40+ phones still have the wolf head. They are all cisco 7940’s running SIP. When I check my phone status I get a msg that says W250 TFTP Error: Timeout dialplan.xml and a lot of the other phones say something along the lines of error parsing SIPDefault.cnf. All the settings are correct in the network section of the phone. I don’t know if they updated or they are just correct since when I rebuilt the system I used the same IPs and info and that old stuff is still in there and happens to match up. I think the problems are all happening because the phones might not be seeing the asterisk server or something but they are still working. Here’s a little more detail. When I set it up it gave me the option to use asterisk as a dhcp server but it sounds like if I do that, since the computers all use the switch through the phone, that I would have to use asterisk instead of the Win server 2008 that is handing out IPs currently. I have a static IP set in asterisk of .25 and I set a reservation in server 2008 for that MAC address but it never is active. Basically, even though the phones are all working it seems as though asterisk isn’t ever taking out a lease on 2008 dhcp server. Is it not able to find the Windows server? Something to do with DNS? I have this in the DNS settings for asterisk
127.0.0.1
XXX.XX.X <public DNS
XXX.XX.X <public DNS

I even tried adding a line with 192.168.0.3 in there which is my windows 2008 server but no help. I ave option 150 and option 66 set up in windows server and all the settings are the same in the new asterisk server as the old asterisk server. Except maybe for the DNS, I never checked it on the old asterisk server. I tailed the var/log/messages for tftp activity and there seemed to be very little to none when unplugging phones and plugging them back in. The DNS in the phone is set to the windows 2008 server. Should it be the asterisk box IP? I was going to change it to give it a try but after unlocking the config there isn’t an option to edit that field in the phone. I don’t use NAT. It’s set to “no” in the SIPDefault and “no” on each extension. Lastly, resetting a bunch of the phones and deleting the network info results in this:
Phone comes up and there is correct info in the network config area of the phone. I check the status and it says something along the lines of No valid line names provisioned (even though they are) and then a bit of time goes by and the phone comes up and is ready to go but still has the old logo and the status now says error parsing SIPDefault.conf. I didn’t attach any files cause I mentioned quite a few in here and I don’t even know where to start but if you need some just post it and I will have them on here in a min or two after you tell me which ones you need. Thank you so much for sharing your genius with me. I really do appreciate all the help.

If you are using DHCP it is unwise to have two dhcp servers running on the same network unless you know what you are doing, requests to the DHCP server will return where 150 and 66 might be at your windoze DHCP server is almost certainly not doing anything right ;-). Use static IP’s on your phones and hardcode the tftpserver to use.

I am pretty sure that DHCP is only being used on the windows server. I checked in the setup>services of the asterisk server and didn’t see anything referring to dhcp in there. I was thinking the basic setup was that the asterisk server hosted the tftp and when the phone is powered on it should pick up and ip from the windows server via dhcp and see the option 150 and 66 which points it to the asterisk box to access the tftpboot folder right? I had this exact setup with my old system and it seemed to work fine. I can’t figure out why when I go to the address leases in 2008 it doesn’t show the asterisk server on the .25 IP. Even if I keep the static ip of .25 set in the asterisk server and remove the reservation in the windows server, asterisk doesn’t ever show up on that address in windows server

I am pretty sure that any client that is looking for DHCP will so broadcast for it, I am pretty sure that the first server that responds on udp 67 will be used, that might not be what you want.

netstat -naunt|grep :69

from the FreePBX box to make sure it is not offering DHCP

if you change /etc/xinetd.d/tftp to reflect

server_args = -s -c -vv /tftpboot

where -vv is verbosity, then the tftpd transaction will show up in /var/log/messages.

As to your windoze deployment, I can’t help, I stopped using their servers years ago for good reason.

netstat -naunt|grep :69 returns this:

udp 0 0 0.0.0.0:69

this is the tail i got:

Oct 23 15:25:28 trixbox2 xinetd[11846]: START: tftp pid=11862 from=192.168.0.113
Oct 23 15:25:28 trixbox2 in.tftpd[11863]: RRQ from 192.168.0.113 filename CTLSEP001B535CC88F.tlv
Oct 23 15:25:28 trixbox2 in.tftpd[11863]: sending NAK (1, File not found) to 192.168.0.113
Oct 23 15:25:28 trixbox2 in.tftpd[11864]: RRQ from 192.168.0.113 filename SEP001B535CC88F.cnf.xml
Oct 23 15:25:28 trixbox2 in.tftpd[11864]: sending NAK (1, File not found) to 192.168.0.113
Oct 23 15:25:28 trixbox2 in.tftpd[11865]: RRQ from 192.168.0.113 filename SIP001B535CC88F.cnf
Oct 23 15:25:28 trixbox2 in.tftpd[11866]: RRQ from 192.168.0.113 filename SIPDefault.cnf
Oct 23 15:25:28 trixbox2 in.tftpd[11867]: RRQ from 192.168.0.113 filename ./SIP001B535CC88F.cnf
Oct 23 15:25:28 trixbox2 in.tftpd[11868]: RRQ from 192.168.0.113 filename P0S3-08-11-00.loads
Oct 23 15:27:04 trixbox2 in.tftpd[11879]: RRQ from 192.168.0.113 filename SIPDefault.cnf
Oct 23 15:27:04 trixbox2 in.tftpd[11880]: RRQ from 192.168.0.113 filename ./SIP001B535CC88F.cnf
Oct 23 15:27:07 trixbox2 in.tftpd[11881]: RRQ from 192.168.0.113 filename RINGLIST.DAT
Oct 23 15:27:07 trixbox2 in.tftpd[11882]:
RRQ from 192.168.0.113 filename dialplan.xml

and when I check the phone it is up and operational but still with the old logo on it which i assume means it didn’s grab the new settings. The phone works. Status has two errors that say something about REG retries exceeded and error parsing SIPDefault.cnf

thoughts?

Don’t assume, it did get all the files that where available some more than once for example

Oct 23 15:25:28 trixbox2 in.tftpd[11866]: RRQ from 192.168.0.113 filename SIPDefault.cnf
.
.
Oct 23 15:27:04 trixbox2 in.tftpd[11879]: RRQ from 192.168.0.113 filename SIPDefault.cnf

So maybe there is something wrong with the files. it is called TrivialFTP for good reason

does that line indicate that it completed the receiving of that file or that it simply attempted getting the file twice?

Also, is there anyone in here that is familiar enough with server 08 that might know why the asterisk server isn’t showing in the address leases and how to remedy that problem?

Probably because you have it set for a fixed IP.

You seem very confused about the roles.

Do you have the tftp server configured on your Asterisk server?

What device on the LAN segment is doing DHCP?

Do you have option 66 and 150 defined properly in DHCP?

Did you turn up verbosity on the tftp service as dicko showed you in the xinetd script?

Did you restart the xinetd service?

Have you tailed /var/log/messages while a phone boots?

How did you migrate the config files, any ownership or access issues?

Lot’s of questions that need to be answered.

-the tftp server is up and running on the asterisk server.
-most of the other questions are already answered above.
-the Windows server 08 is doing the DHCP. asterisk is set to static but isn’t showing in the address leases on win server. I think that is a lot of the problem.
-I have option 66 and 150 defined in the server options on windows server and they are both pointing to .25 IP which is the asterisk server
-I did make the changes as dicko provided, restarted the xinetd service, and the tail is posted above
-the config files are all 777. I don’t know a ton about linux but was told to change them to that. let me know if I should switch them to something else.

As an update. I downloaded a new sample SIPDefault.cnf, changed the settings for my system, and put it in the tftpboot directory with 777 permissions. I restarted a phone and it looks like everything took. I even have the new logo but it still says error parsing SIPDefault.cnf and unprovisioned backup proxy address in the status message of the phone. Is it possible that it is trying to parse the file, having a problem and posting the message, and then trying again and completing the second time?.

Just something else I noticed:
in the CLI i noticed a couple warning messages on reload. Not sure if they are anything to worry about or not.

[2012-10-24 12:30:18] WARNING[20285]: app_flite.c:77 read_config: Flite: Unable to read config file flite.conf. Using default settings

[2012-10-24 12:30:18] ERROR[20285]: res_clialiases.c:183 load_config: res_clialiases configuration file ‘cli_aliases.conf’ not found
– Reloading module ‘res_phoneprov.so’ (HTTP Phone Provisioning)

Static IP’s won’t show in the leases file of a DHCP server because they are not asked for or leased , they are static. Your Asterisk server really needs to be statically assigned

Your phones will use the first DHCP server that responds to the request, as previously stated. If they ask for 66 or 150 or any other DHCP service they will use what they are given, so if you truist your windoze box use it.

As previously stated TFTP stands for TrivialFTP it is a UDP protocol and just sends what the client asks for if it has it. If the phone asks twice for the same file it will send it twice but there is no error checking or acknowledgement of safe receipt in the protocol. If the phone complains about a file, it is nothing to do with the tftp server you will jut need to supply an accably structured and formatted file to suit.

all of my static addresses show up in the address leases except that one. I have a couple reservations for my spa8000 boxes and if I go check. it says active beside it but even if I set a reservation for the asterisk box and take it off static, it still doesn’t take that IP. It just picks up a random IP. Thats why it makes me think its something to do with the DNS.

IMHO the asterisk box should NEVER be using DHCP for it’s address, exactly as you do for your spa8000 boxes, it should ALWAYS use a static IP outside of your DHCP server’s range of assignable addresses, if it doesn’t then you will have to change all sorts of things on your firewall if the IP changes and only be able to use names and not addresses that are resolvable by each and every phone on your localnet.

completely agree. I only changed it to dynamic for a second while I had it on the test block to see if it would fill the reservation but it didn’t. I have it in static now but I just have an erie feeling something is not right with the DNS. What should my network setup be in asterisk if I have a static address of .25 and am using the windows server to hand out dhcp?

Also, any thoughts on the warning I posted above? anything to worry about?

From your previous posts I assume your IP should be 192.168.0.25 (and 25 is NOT within the address range offered by the DHCP server) netmask presumably 255.255.255.0, gateway as appropriate to your network.

In /etc/asterisk/sip_nat.conf

localnet = 192.168.0.0/255.255.255.0
externip=(use it if static)
or
externhost=hotname.domain.tld (if the external ip is dynamic) a good reference to what you will need depending on your network a possibly pre-emptive tutorial :-

http://www.asteriskguru.com/tutorials/sip_nat_oneway_or_no_audio_asterisk.html

or use the GUI Sip settings page.

If you use IP addresses for all your internal IP phones, then you don’t need DNS for them. How you setup your router and external DNS is well documented.

Technically a “Dynamic Host Configuration Protocol” Service hands out any Host configurations like IP addresses, server addresses for NTP, TFTP and any of dozens of other services depending on mac address and vendor identification , not actually as you put it “dhcp”, your software vendor for your dhcp server will have that documentation. A good starting point might be

the warnings are as they say, in your case they are normal informational warnings that you have not configured those parts of Asterisk.

my sip_nat.conf file is blank…

not to throw too many things in here at once but here’s something else I noticed.
I have one extension that works fine. I can call it from internal or from an outside line but if I transfer a call to it then it goes straight to voicemail without ringing. Any ideas where I should check on that one?