Unknown DID in Trunk, send 404 don't answer

What changes do I make and where to return a sip 404 on a specific trunk rather than answer and play message?


Please don’t confuse trunks with DID’s and inbound routes, if there is no specific matching inbound route for a DID/CID condition, then a 404 will be sent by default.

How come the call gets answered, I need it not to be answered. I am trying to tell my VOIP vendor that I am not the target for a specific DID so it gets routed to another device outside my FPBX server.

If you don’t have a matching inbound route, then it should not be answered, maybe you have allow anonymous callers allowed ? . . .

In gen settings anon is off, but in SIP, allow guests is on.

I thought you said that you didn’t like “guests” :wink:

Is this the solution to my problem? Turn guest off?

Do you have an Any/Any incoming route defined? If so that will allow any Incoming DID in. One thing you could do is define the errant DID and route it to TERMINATE CALL.


Great idea, unfortunately, by working with my VOIP vendor, FLOWROUTE (who I like very much), we discovered that setting terminate call sends a SIP 603 rather than a SIP 404. Apparently a 603 says reject call for all possible answerers not just for this answerer. I understand that 404 allows the call to continue to seek other answering parties, which is what I would like to do.

I also notice that there seems to be no mention of the SIP code response in the asterisk log.