Uncomfortable 5-15 seconds of silence on some outbound [solved]

On certain outbound calls (it depends on the called number), there is an uncomfortable 5-15 seconds of silence before the connection actually occurs and you hear ringing. A lot of people would immediately misinterpret the silence as “Not dialing” and will hang up.

Is there a way to fix it? Debug it?
Any thoughts?

No thoughts without knowing more about your system.

Centos 6.x
Asterisk Ver.
SIP only trunk to the provider

Are you appending your dialed number with a “#” or pressing the “Dial” button on your phone after entering the number?


Ok. I understand what you mean. You are implying that “#” would start dialing right away without waiting for further input. Correct?

Yep…as would pressing the dial button. Kind of like a cell phone. There is a timeout that tries to dial 4 seconds after the last button was pressed.

Many phones support “On Hook Dialing.” Dial the number before the phone is picked up, then when you pick it up, the number is dialed immediately.

There could be other causes, but this is a place to start.


Is there a place where you can specify how long you want system to wait after last dialed digit before deciding it’s time to dial?
Either through freepbx web gui or through the termianl.
I would like to reduce waiting from 15 sec. to something more reasonable.

How long the phone waits and how you change the wait is dependent on the brand of phone. What brand of phones are you using?

regular phone(s) through PAP2T adapter. PAP2T points to my asterisk server NOT to my sip provider. Asterisk server has sip trunk to sip provider.
I guess I have to dig to my pap2t settings?

Changing my dial plan on PAP2T seems to reduce delay drastically.
Consider it solved.

Yes, you can press pound on the PAP2 but the correct way is to setup the dial plan. You should be able to configure the PAP2 so that it starts dialing instantly after you enter the matched dial string in the dial plan on the PAP2.

I know, but there are several places you can setup you dial plan in:

  • ATA adapter
  • outbound route
  • trunk

Originally I put (**|*x.|xx.) as a dial plan for ATA adapter, and “real” dial plan to the outbound route. The idea behind it was to let outbound route to format/fix/decide how to dial out. Now, I replace it the dial plan which is almost exact from my outbound route. I should probably fix the issue.