FreePBX | Register | Issues | Wiki | Portal | Support

Unable to write to directory


(Adam Kayden) #1

I received this error after choosing Auto-Deploy in monitoring server setup.

Error!
Exception [ Error ]:
Unable to write to directory /var/www/m3/packages/ansible/cfg
APPPATH/packages/ansible/classes/core.php @ line 36

I tried to doing this and it does not work -
[root@M3 www]# chown nobody:nobody m3

this is running on CentOS 6.6 in Azure Cloud.


(Dave Burgess) #2

Is the error coming from Asterisk (owner usually asterisk) or from the webserver (owner usually www). I can’t think of a situation where “nobody” would be the right owner for that file.

If you are running a program from the command line, you should be deploying this as ‘root’, in which case the directory permissions would be ignored until you went to use the application.


(Eduardo Viegas) #3

chown -R asterisk:asterisk /var/www/m3/packages/ansible/cfg


(Adam Kayden) #4

i install this as root (sudo -i) as Azure does not enable root by default. The command below does not get this to work.


(Rob Thomas) #5

Well, that’s going to be a problem. I’ll fire up an azure machine and see what I can do to work around that.


(Rob Thomas) #6

However, this just occured to me - last time I looked, Azure didn’t support ICMP or UDP communications. This means it’s not going to work ANYWAY.

goes and checks

OK, They now allow UDP, but ICMP is still blocked. Your monitoring is not going to work. Please don’t use Azure. There are plenty of other places that don’t randomly filter a critical part of IP, so you should probably use one of them.

I’ve just updated the Installation page to explicitly say that Azure will not work, and to pick something else. Sorry about that.


(Adam Kayden) #8

thanks @xrobau for trying this out. It helps a lot. i’ll sign up for Amazon and give it a try…