FreePBX | Register | Issues | Wiki | Portal | Support

Unable to update

bug
Tags: #<Tag:0x00007fb9015403a0>

(Garry Winer) #1

I have FreePBX 10.13.66-2 and am using the System Admin module. I am trying to update to the latest version and am getting errors:
2015-12-29 01:00:01: () Update already in progress (locked)2015-12-30 01:00:01: () Update already in progress (locked)2015-12-31 01:00:02: () Update already in progress (locked)2016-01-01 01:00:01: () Update already in progress (locked)2016-01-02 01:00:01: () Update already in progress (locked)

I have tried to reboot the server and still get the same error. All my modules are up to the latest version, however I can not get the system to update to the latest version.


(Marbled) #2

Hi!

It sounds like you are having a problem similar to this:

I have a feeling that, like in that situation, you have files left from a previous failed installation which are “locking” you out from running an update script again until they are out of the way…

I hope that you have backups before even if you find out what they are and are able to run the rest of the script there is a possibility that your installation might be hosed…

Good luck and have a nice day!

Nick

PS: Personally I have always had better luck running the update scripts manually…


(Tony Lewis) #3

from the CLI issue
/usr/sbin/sysadmin_update_system --unlock


(Garry Winer) #4

That fixed the issue. Thanks very much for your assistance. My system is now fully updated to the latest version.


#5

Thank you! Fixed a stuck update for me as well! It said started HA maintenance mode (I don’t have HA) and stopped there.


(Phil) #6

Worked for me as well. What whould cause this? I poked around to see in any of the temp files and logs and found noting. The upgrade that this happened on was between 10.13.66-17 -> 10.13.66-18.


(Tim Müller) #7

Thank you for posting this solution, had the same problem during my last update and this command resolved it!


(Marcelo) #8

Thanks, worked for me too!


(atcomsystems.ca) #9

I also just noticed this issue on a 10.13.66-17 system with auto-updates turned on.


(Marc Abbaticchio) #10

Tony to the rescue once again!
Thanks.


#11

One note, when doing the “/usr/sbin/sysadmin_update_system --unlock” command, be logged in as root not your own account.