Unable to update Bulk Handler


(Rick H) #1

I am getting the following notification: bulkhandler (Cur v. 13.0.23) should be upgraded to v. 15.0.11 to fix security issues: SEC-2021-011. However, I cannot update the module. I tried removing the module and then adding it back, but it just comes back at 13.0.23.
PBX Version: 15.0.17.53
PBX Distro: 12.7.8-2107-3.sng7
Asterisk Version: 16.17.0


#2

I just came here to report the exact same issue, except on mine it says “Vulnerable, Requires: 13.0.25” but the only version available is 13.0.23. This is on FreePBX 14.0.16.11 running on a Raspberry Pi.


(Itzik) #3

Try:

fwconsole ma uninstall bulkhandler
fwconsole ma delete bulkhandler
fwconsole reload
fwconsole ma listonline
fwconsole ma downloadinstall bulkhandler
fwconsole r

(Rick H) #4

Nope. This is pretty much what I did from the GUI. It just reinstalls 13.0.23.


(TheJames) #5

Try the --edge flag incase the module is still in edge
edit:
Just pulled the module.xml and it isn’t in there… @mattf @lgaetz it looks like the “fixed” version may not be published


(Lorne Gaetz) #6

Noted


#7

I have run into the same issue, and unless I used the wrong command, it’s not working telling me 13.0.23 is the lastest.

fwconsole ma upgrade bulkhandler --edge
Edge repository temporarily enabled
No repos specified, using: [commercial,extended,standard] from last GUI settings

bulkhandler is the same as the online version, unable to upgrade

I remembered I can also try to tag the version, same result:
[[email protected] ~]# fwconsole ma downloadinstall bulkhandler --tag=15.0.11
No repos specified, using: [standard,extended,commercial] from last GUI settings

Unable to update module bulkhandler - 15.0.11, it does not exist:

(TheJames) #8

I think maybe @kgupta1 does all the publishing. It is morning there now so hopefully this will resolve this.


(Kapil Gupta) #9

Please check now, bulkhandler v13.0.24 for the Freepbx 13/14/15 and v16.0.3 for 16 should be available now which has the security fixes. Security fixes release wiki also updated with module informations.

thanks


(Rick H) #10

It now updates to 13.0.24. Looks like it is working now. Thanks!


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.