Unable to transfer calls


Got this problem where user is able to transfer calls normally but when changed connection to other ISP, suddenly unable to transfer calls. Making calls is working fine. Logs indicating that we are not including the ‘Refer-To’ target, when in fact the transfer request does include that, However, they still respond with a 400 error, indicating that it is missing. Any ideas on what could be the problem? Thank you.

Please describe the overall setup in some detail:

What equipment is “we” (an IP phone, a FreePBX system, something else)?
What is “they” (a FreePBX system, a trunking provider, something else)?
Who has the new ISP (“we”, “they”, someone else)?

If a remote extension such as an employee working from home (or at a branch office that does not have its own PBX) lost the ability to transfer calls, the problem is likely a SIP ALG in the gateway (combination modem/router) supplied by the new ISP. If this is your situation, possible fixes are:

  1. Turn off the ALG, if this gateway setting is available to the user, or if the ISP can do it for him.
  2. Avoid the ALG by using a port other than 5060, at both the device and the PBX.
  3. Use SIP over TCP or TLS instead of UDP.
  4. Connect via a VPN.
  5. Put the gateway in bridge mode and use a separate router.
  6. If the ISP permits, use your own modem and router, or your own gateway.

However, if the PBX is commanding the trunking provider to transfer the call, that is an unusual setup not supported by FreePBX at all, presumably implemented by custom Asterisk dial plan code. If this is your case, please provide details.

The remote user working from home who is able to transfer calls using ISP A is not able to transfer calls using ISP B. The VoIP provider is indicating that the softphone is not including the ‘Refer-To’ target, when in fact the softphone transfer request does include that. Thanks for feedback, will check on the settings.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.