FreePBX | Register | Issues | Wiki | Portal | Support

Unable to successfully install


(Jack Hill) #1

Hi All,
I have tried pretty much everything I can to try and get FreePBX installed on a NUC7i5BNK, including advanced installation and old versions, however, nothing I try seems to be working for me. The error that I get is the most useless error I’ve ever seen “An unknown error has occurred” This happens in custom installs as soon as FreePBX GUI is selected.

I cannot upload photos of the error due to being a new member but do have them on imgur. I know not having network connected in the past has caused issues, however, for this I have tried both ethernet and wifi. Both get an IP and can be seen from the network.


(Jack Hill) #2

Link to error message screenshots https imgur com/a/B2fxs (sorry about obscure link, had to do it due to being new member)


(Tom Ray) #3

That’s because the NUC’s use hardware/memory that CentOS/RedHat doesn’t support. In fact most NUC’s and other systems like NUCs generally only list Ubuntu as the supported Linux OS outside of Windows OSes they support.


(Jack Hill) #4

So I’ve had a bit more of a play around and it appears that it is an issue with the Python install in CentOS, as a bare minimum install will work but a standard install will not. It is failing on python-libs which to me suggests it is not a hardware compatibility issue.


(Tom Ray) #5

Yes, that is where most installs die actually and due to the memory on the system. You know, the hardware.