FreePBX | Register | Issues | Wiki | Portal | Support

Unable to sign in to community


(Jared Busch) #1

Recently got a new laptop and installed Korora 25 Cinnamon on it.

Using both Firefox and Chrome, I am unable to sign in to the community.

I can log out and back in using the same credentials (LastPass) on my iPhone and iPad.


(Andrew Nagy) #2

Works fine here


(Jared Busch) #3

And that helps how? I clearly stated the problem and included an image.

Works fine for you on what OS and browser?

My desktop is also Korora 25 and I have the same issue.

I just checked my MacBook Pro running macOS Sierra. Same problem when using Chrome, but it worked in Safari.


(Raphael Waller) #4

Had the same problem. Made a password reset request and now working.


(Andrew Nagy) #5

Sure. But how does it help to state what you stated. Either way it doesn’t work for you sometimes but it works for me and others on our staff all the time.

Take into account that we don’t write the forum software so many of the issues it has are out of our control.

Hard to know where to go with that without it being reproducible.

This is what it worked for me on. Chrome + Mac


(Jared Busch) #6

Wow, serious WTF here…
Sangoma should think about hiring a community manager.

This is clearly a problem with the something on the platform. 3 clean installs all exhibit the same behaviour on an account. This mean either a bug in the platform or a bug on the specific account.

Either way, it is not the problem of the user.


(Jared Busch) #7

Thanks. This resolved my problem, but why would I need to perform a password reset when the password works on other devices.

This also tells me the problem was related to the platform or account itself.
So again, @tm1000 not something a user should be expected to deal with.

Also, surprise, the reset process had problems.

So I click reset password, put in username and email, received this email.

clicked link and got this error.

Vlicked link there, entered username and email again, which resulted in this email,

Which finally let me change my password.


(Andrew Nagy) #8

Are we talking about logging into the forums

I’m sorry you have an issue with my responses I’m just trying to be straight forward in my responses.

As for password resets there is no way I could have known that. I responded to simply let you know it’s not happening for someone else but it seems you inferred it differently. I didn’t mean it in anyway like that and I don’t know why it’s still continuing down this route of increased aggravation. Really. I don’t mean anything by this. I was just trying to provide more information.

To be honest eveything you are having issues with we don’t have issues here. That is all I saying. If I looked into it and I don’t have the issue would you like me to forward it on to some else. What if that person doesn’t have the issue. These are honest questions and this is what we did initially when I said it works for me.

We get tickets like this in the ticket system sometimes and I get the same responses back. I’m honestly baffled at how to respond. We could just let this sit here and nothing could be said. Maybe that’s the proper action moving forward?

I’ll forward this on to our community manager @jfinstrom . Which we have. Are you requesting I not reply in the future?


(TheJames) #9

As mentioned we use a 3rd party application for our forums which we have limited troubleshooting abilities on. Your best bet is to go to meta.discourse.org which is the software maker’s forum. They also run on discourse. You might try creating an account there and see if you can reproduce the issue on theirs. If so they have full debug ability for discourse bugs


(Marbled) #10

Hi!

Maybe I am misreading this but it looks like the problem might be with Atlassian Crowd, the software you use for SSO (see https://www.atlassian.com/software/crowd).

There is an official Discourse plugin for Atlassian Crowd available here: https://github.com/discourse/discourse-crowd but it’s not what Discourse use natively I believe and unless the problem is with that plugin you might want to get in contact with Atlassian.

(IIRC Atlassian provides their software and believe support free to open source projects…)

Have a nice day!

Nick


(TheJames) #11

Discourse also wrote the crowd plugin


(Marbled) #12

Hi,

I know, this is why I said this

(I was referring to the Atlassion Crowd plugin made by Discourse…)

It looks like it’s Atlassian Crowd which is misbehaving not Discourse and since Discourse has it’s own in-house SSO module (see https://meta.discourse.org/t/official-single-sign-on-for-discourse/13045) the chances of them using the Crowd one are close to none…

Have a nice day,

Nick


(Marbled) #13

Atlassian Crowd, according to its sales literature, combines different directories together so that they essentially apppear as one…

To me it sounds absolutely plausible that one of those directories had problems when Jared was trying to login earlier while another, like the one Sangoma employees use, was still functional and letting you guys logon…

I could be wrong but I have a feeling Sangoma employees logins are not in the same directory as our logins…

If what I am suggesting is what actually happened then the only people who stand a chance at finding the problem are you with the help of Discourse and, quite likely, Atlassian since the answer is in your logs…

Have a nice day,

Nick


(TheJames) #14

The logs we have are generally useless honestly. There is no way for us to decipher anything useful from what they present to us.

Crowd has separate directories but we don’t use them. The employees are actually on the same directory as everyone else we just have different groups assigned to us. Those groups are not accounted for by discourse we actually manually grant privileges.

Ops issue is it works on some of his browsers and not others. The fact that it works in some browsers further supports an environment issue over a bug. This in mind if the headers are sent weird or the cookies are messed up this may break something we don’t know how to troubleshoot

An example line from our logs

	
(crowd) [retrieve_user_info!] response body: <?xml version="1.0" encoding="UTF-8" standalone="yes"?><error><reason>USER_NOT_F

Yes it is half missing and 100% useless.
A user was not found… Cool what user, from where.

We have heavy traffic legitimate and bots. I have no way to know if this is a valid request with a typo or some bot scanning usernames


(Marbled) #15

Hi!

And no way to change the logging level I guess?

OK… I was expecting something more complex than that…

I agree that there is something quite peculiar about this and there is most likely a pretty weird explanation for it (which I have no idea what it is at this time :disappointed:).

However, in theory, your logs should provide you with the necessary information to debug this while on his side he only sees the end results of something apparently being mangled…

Since he was able to “fix” his problem by resetting his password and then everything worked (and from what I gather it fixed his problem even where it did not work) it’s not like something is continuously mangling what he receives on a specific platform.

It sounds to me that it is more likely that the problem is on your side (or if it is on his you could have provided him with information to track it down) but

I understand your point, this is totally useless…

The only thing I could suggest is to ask the Discourse and Atlassian people (so that you could actually “see” what each one “sees”) if there is any way to have more meaningful logging…

I know, Discourse is open source and you probably got a free licence of Atlassian products because of the open source aspect of FreePBX (I don’t know if they still do this but I know they used to) but there is quite likely a way to get help and surely there is something that can be done so that the next time something like that happens there is actually a way to track down what is happening.

Now that I see how useless that logging is I understand the answer both of you gave but I also understand the OP frustration since, normally, if Discourse and/or Atlassian Crowd produced more meaningful logging, you should be able to help him with his login problem…

And while I think everyone is entitled to get help in that situation I would understand even more him being frustrated if he is a paying customer which has invested (or had his clients invest) a lot of money in Sangoma’s products…

I totally understand everyone’s answer given the situation but the question now is are things left as they are currently or can something be done so that the next time this happens the burden of finding out what the problem is (or at least “fixing it” by doing a password reset") doesn’t entirely fall on the person which, in theory, has the least information needed to debug it?

(I don’t like the “reset password fix” but, when all else fails, at least it provides a “solution” the problem…)

Have a nice day!

Nick


(Andrew Nagy) #16

Sure. He can send us his password. That is the only way.


(Luke C) #17

People need to give it up, discourse is an open source forum platform. Let these developers focus of other issues that actually matter, just be happy this community isnt ran on phpbb.

I have installed and managed both, discourse is a blessing compared to other open source alternatives


(Marbled) #18

Hi,

Considering he no longer has a problem I am not quite sure what could be done now…

Thank you for your time and have a nice day,

Nick


(Marbled) #19

Hi,

So?

Open source developers are as much interested into fixing issues than any other…

I know, I was one for many years and left only a few days ago because it was time to move on…

It wasn’t my first nor hopefully my last contribution to open source…

As for Discourse, I am sure that if they can be of any help to track down a problem either the developers or their community would be glad to do so…

Honestly, I doubt Discourse is to “blame”, my bets are more on Atlassian Crowd and while Atlassian is open source friendly (see https://www.atlassian.com/software/views/open-source-license-request to see why I say that) and has at least one of their project as open source most of it is not…

Trust me, I definitely have nothing against open source and I have proved so by not only using open source programs but by actually contributing back code, translations, etc… back to them…

Not being able to actually use it by not being able to log on is an issue that matters to me and to most people I believe…

I have never done either but it sure seems like a nice forum software…

If what I wrote above had you think

  • that I was complaining about Discourse

or

  • that I was complaining about open source

Maybe I said something which got misinterpreted somewhere but the only software I suggested might be the source of these problems is nor Discourse nor open source, it’s Atlassian’s Crowd…

Giving the lack of any meaningful logging from the involved software I perfectly understand everyone’s answer…

That said, I don’t think status quo, ie not doing anything, is the preferable solution here… It’s not the first time this happens and, as Andrew put it:

(Essentially they are unable to help and the user is left with figuring out a solution to her/his problems by herself/himself…)

Open source or not I am sure that the involved parties (Discourse and Atlassian) would be happy to fix any possible issues with this as long as they are made aware of them…

I am also sure that Sangoma as well would be happy to be able to provide more help when people are unable to logon their forum…

Have a nice day,

Nick


(Luke C) #20

If your about bettering the community, spin up a VM of discourse on digital ocean (very easy). Try and replicate the problem, find the issue and report back. I am sure it would be greatly appreciated…