Unable to set the outgoing CID

I had set an new freepbx and setup it finally its started working i am getting both inbound and out bound i mean i can get the incoming calles and i can make outgoing call’s
My problem is i am unable to set my local extension as my caller id

I had an main PBX server in my own office and so i had configured an new PBX in my branch office, i had buyed totally 10 numbers which are as follow
6XX5XXXXX1 to 6XX5XXXX10 i had kept 5 numbers in my own office an taken and configured another 5 numbers in my branch office there is no problem of outgoing caller id in my Head office but i am facing an problem in my branch office in my own office one of friend had configured it 3 years back and i am new to the pbx so please help me how to set my ext as my caller id in my caller id i am getting the id as 6XX5XXXXX1 only

Does your provider allow setting the caller id. Some providers do and some don’t.

without knowing a lot more details we can only guess.

What is your trunk type? SIP, zap/Dadhi, IAX, POTS, etc…

Different types of trunks have different rules. POTS you can’t set, SIP will depend on your provider allowing you to or not.

If you are located in the US it is against the law to use a CID that you do not own and because of this many providers place restrictions on you. Some have to do it for you, some will only allow you to set the number you are allowed to use. i.e. if you have two providers with two different set’s of numbers, it is possible that each provider will only allow those numbers they gave you and not others.

So without you providing some real details we can work with it is hard to answer your question with specific directions.

What version of things are you using? FreePBX, etc…