Unable to run install -n

This is running on RHEL 7, with Asterisk 14 (latest version) and version 14 of Freepbx

I followed Asterisk install from source from:

Then I followed:

I seem to have worked around most issues that arose from this setup however I can’t seem to figure out how to get past this. When running ./install -n from my freepbx folder I get the following:

Checking if SELinux is enabled…Its not (good)!
Reading /etc/asterisk/asterisk.conf…Done.
Checking if Asterisk is running and we can talk to it as the ‘asterisk’ user…Error!
Could not determine Asterisk version (got: Unable to open specified master config file ‘/etc/asterisk/asterisk.conf’, using built-in defaults).
Please report this.

This is coming from asterisk when run as:

su asterisk
asterisk -rvvvvv

So in the first line of /etc/asterisk/asterisk.conf I had removed the ! in the first line directories because of another article I had found (linked below). I’ve put the ! back into the file and now I’m just getting the same error as described in the link below.

Reading /etc/asterisk/asterisk.conf…Error!
Unable to read /etc/asterisk/asterisk.conf or it was missing a directories section

You can’t have the ! in the file.

Did you even run the commands I discussed?

I am curious about that (!) in the file, of how it got there. I see it has now gone from your repos to others such as EPEL, and Debian ones.

I did run the commands but I got the follow message"

Inheritance requested, but category ‘’ does not exist, line 1 of /etc/asterisk/asterisk.conf
Unable to open specified master config file ‘/etc/asterisk/asterisk.conf’, using built-in defaults
Asterisk 14.6.2, Copyright © 1999-2016, Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type’core show license’ for details

Connected to Asterisk 14.6.2 currently running on COMPUTER (pid =1764)

When I added the (!) back into the config file and ran the same commands I got the same output except for the first 2 lines.

@geekboy it was there by default when I installed Asterisk.

You should just post your /etc/asterisk/asterisk.conf file here.

Nothing should be there by default.

It was in there by default when I originally came across this. It just happened again while fooling around with a Debian disto a couple of weeks ago, and installed FreePBX from their repos. I think it came from the FreePBX end since I did originally see this in and installation from your .tar package.

It does not come from the FreePBX end.

Then from the Asterisk side? I have not looked, but does FreePBX install call on Asterisk to write that asterisk.con file, or or does the FreePBX installation script write to it?

FreePBX will write it usually. However freepbx then needs to read it directly after and it doesn’t understand the ! directive. So while you might assume FreePBX writes that if it did no installs would work (The distro uses the same install as everyone else)

It’s not letting me upload or share a link. I’ve had to butch a URL to get the config there.

dropbox.c om/s/uyy0ebsfj3t9lyk/asterisk.conf?dl=0

You did not share that link correctly. Just paste the text in here

The file from dropbox is corrupt as well.

Hey guys. Thanks for your patience with me on this. I’ve attached the text below: *Note directories line 1 is in square brackets with two regular curved brackets immediately after.

astetcdir => /etc/asterisk
astmoddir => /usr/lib/asterisk/modules
astvarlibdir => /var/lib/asterisk
astdbdir => /var/lib/asterisk
astkeydir => /var/lib/asterisk
astdatadir => /var/lib/asterisk
astagidir => /var/lib/asterisk/agi-bin
astspooldir => /var/spool/asterisk
astrundir => /var/run/asterisk
astlogdir => /var/log/asterisk
astsbindir => /usr/sbin

;verbose = 3
;debug = 3
;refdebug = yes ; Enable reference count debug logging.
;alwaysfork = yes ; Same as -F at startup.
;nofork = yes ; Same as -f at startup.
;quiet = yes ; Same as -q at startup.
;timestamp = yes ; Same as -T at startup.
;execincludes = yes ; Support #exec in config files.
;console = yes ; Run as console (same as -c at startup).
;highpriority = yes ; Run realtime priority (same as -p at
; startup).
;initcrypto = yes ; Initialize crypto keys (same as -i at
; startup).
;nocolor = yes ; Disable console colors.
;dontwarn = yes ; Disable some warnings.
;dumpcore = yes ; Dump core on crash (same as -g at startup).
;languageprefix = yes ; Use the new sound prefix path syntax.
;systemname = my_system_name ; Prefix uniqueid with a system name for
; Global uniqueness issues.
;autosystemname = yes ; Automatically set systemname to hostname,
; uses ‘localhost’ on failure, or systemname if
; set.
;mindtmfduration = 80 ; Set minimum DTMF duration in ms (default 80 ms)
; If we get shorter DTMF messages, these will be
; changed to the minimum duration
;maxcalls = 10 ; Maximum amount of calls allowed.
;maxload = 0.9 ; Asterisk stops accepting new calls if the
; load average exceed this limit.
;maxfiles = 1000 ; Maximum amount of openfiles.
;minmemfree = 1 ; In MBs, Asterisk stops accepting new calls if
; the amount of free memory falls below this
; watermark.
;cache_record_files = yes ; Cache recorded sound files to another
; directory during recording.
;record_cache_dir = /tmp ; Specify cache directory (used in conjunction
; with cache_record_files).
;transmit_silence = yes ; Transmit silence while a channel is in a
; waiting state, a recording only state, or
; when DTMF is being generated. Note that the
; silence internally is generated in raw signed
; linear format. This means that it must be
; transcoded into the native format of the
; channel before it can be sent to the device.
; It is for this reason that this is optional,
; as it may result in requiring a temporary
; codec translation path for a channel that may
; not otherwise require one.
;transcode_via_sln = yes ; Build transcode paths via SLINEAR, instead of
; directly.
;runuser = asterisk ; The user to run as.
;rungroup = asterisk ; The group to run as.
;lightbackground = yes ; If your terminal is set for a light-colored
; background.
;forceblackbackground = yes ; Force the background of the terminal to be
; black, in order for terminal colors to show
; up properly.
;defaultlanguage = en ; Default language
documentation_language = en_US ; Set the language you want documentation
; displayed in. Value is in the same format as
; locale names.
;hideconnect = yes ; Hide messages displayed when a remote console
; connects and disconnects.
;lockconfdir = no ; Protect the directory containing the
; configuration files (/etc/asterisk) with a
; lock.
;stdexten = gosub ; How to invoke the extensions.conf stdexten.
; macro - Invoke the stdexten using a macro as
; done by legacy Asterisk versions.
; gosub - Invoke the stdexten using a gosub as
; documented in extensions.conf.sample.
; Default gosub.
;live_dangerously = no ; Enable the execution of ‘dangerous’ dialplan
; functions from external sources (AMI,
; etc.) These functions (such as SHELL) are
; considered dangerous because they can allow
; privilege escalation.
; Default no
;entityid=00:11:22:33:44:55 ; Entity ID.
; This is in the form of a MAC address.
; It should be universally unique.
; It must be unique between servers communicating
; with a protocol that uses this value.
; This is currently is used by DUNDi and
; Exchanging Device and Mailbox State
; using protocols: XMPP, Corosync and PJSIP.
;rtp_use_dynamic = no ; When set to “yes” RTP dynamic payload types
; are assigned dynamically per RTP instance vs.
; allowing Asterisk to globally initialize them
; to pre-designated numbers (defaults to “no”).
;rtp_pt_dynamic = 96 ; Normally the Dynamic RTP Payload Type numbers
; are 96-127, which allow 32 formats. When you
; use more and receive the message “No Dynamic
; RTP mapping available”, extend the dynamic
; range by going for 35 (or 0) instead of 96.
; This allows 29 (or 64) more formats. 96 is the
; default because any number below might be
; rejected by a remote implementation; although
; no such broken implementation is known, yet.

; Changing the following lines may compromise your security.
;astctlpermissions = 0660
;astctlowner = root
;astctlgroup = apache
;astctl = asterisk.ctl

Did you make install samples?

Not that I can recall.

That file is from make samples. Its got comments in it.