Unable to route call through a trunk


i have a trixbox with 1 sip trunk, when i try to make an out going call through trunk i get the following

<— Reliably Transmitting (NAT) to —>
SIP/2.0 407 Proxy Authentication Required

Via: SIP/2.0/UDP;branch=z9hG4bK-12296b-46f1cc5a-19546663;received=

From: "2005"sip:[email protected]:5060;tag=80b02220-57c222f6-13c4-12296b-756d0f02-12296b

To: "02084744553"sip:[email protected]:5060;tag=as2669b608

Call-ID: 80aff100-57c222f6-13c4-12296b-36aa267 [email protected]

The To line “sip:[email protected]:5060” should go to the sip provider but its going to the local address of the trixbox.
how do i get this to route to the sip trunk.

i have a default route pointing everything to this trunk as i only have one trunk

Just a shot in the dark but do you have NAT enabled in the SIP extension setting?

First of all, Trixbox has forked FreePBX so you should probably ask this question in a Trixbox forum and let them deal with it, or switch to one of the distributions that uses true FreePBX such as Elastix, PBX in a Flash, AsteriskNOW, etc. In any case, without seeing your trunk configuration it’s almost impossible for any of us to offer specific help - but I also think people would be more willing to assist you here if you were using true FreePBX, not the silly rabbit forked version which differs from the original in ways unknown to us.