Unable to register extensions


(Ian Gouldbourne) #1

VM disconnects when attempting to register extensions in MicroSip or Xlite. VM is setup with bridged networking. SIP 408 error. I would appreciate any help.


(Franck Danard) #2

Hi
Just need further infromation.

  • What’s your system (FreePBX version, Distor …Etc)?
  • What’s the driver used here? (chan_sip, pjsip)?
  • Maybe check if your some ip address is blocked in sysadmin / intrusion detection. 408 error could be your issue. If your ip is black listed of course. this issue is coming often when you try to set a wrong password for test.
  • Check Asterisk SIP Settings menu. Network, Nat, …etc

Just an idea like that.


(Ian Gouldbourne) #3

Hi Frank,

Thanks for responding.

Presently using 10.13.66 but I have tried others as well.
pjsip

Another thing I just realized is that the initail error from XLite is to verifiy the User Id, password & auth name, after I retry the registration about 3 times, that is when it disconnects.

I enter the extension for the User ID and Authorization name, I have used the default secret password as well as other passwords with no luck.


#4

“default secret password” ??


(Ian Gouldbourne) #5

Yes, the default password created for the extension.


#6

OK, not quite ‘default’ more ‘individually generated’

What other defaults are you using, hopefully your default Channel Driver is chan_pjsip (on udp 5060) and your extension is specifically using that technology.


(Ian Gouldbourne) #7

Noted.
Basically using all default settings. Yes port is 5060.


#8

I suggest you fire up your sngrep in one terminal and see what is happening, at the same time (in another terminal)

 tail -f /var/log/asterisk/full

(Ian Gouldbourne) #9

Package not found for sngrep

tail -f /var/log/asterisk/full shows: No mathcing endpoint found

Request ‘REGISTER’ from “Help Desk”
Help Desk is the display name I entered


(Ian Gouldbourne) #10

I left out this part of the error sip:1001!10.116.117.30 failed for 10.116.117.11:53560 No matching endpoint


#11

sngrep has been a fixture of the “distro” for a while, it is in the current apt (debian flavor) repos, can’t speak for yours :wink:

The terminal I refer to is a linux ‘shell’ of most any variety ‘putty’ or ’
ssh’ qualify just NOT the asterisk CLI interface.


#12

That suggests that you have your chan_pjsip and chan_sip mixed up somewhere.


(Ian Gouldbourne) #13

Not sure how that would happen.


(Ian Gouldbourne) #14

So the problem was a simple issue all this time, the config was not applied :man_facepalming:
Now I just need to set up more extensions.


(Ian Gouldbourne) #15

Thanks for taking the time to help.