Unable to register DPMA license on a new FreePBX install

Greetings,

We are setting up a new deployment in one of our branch offices using a fresh install of AsteriskNOW 6.12 64-bit (installed from scratch twice now with the same issue). We keep running into an issue when we go to register the Digium module in the Connectivity>Digium Phones window. When I click the ‘Obtain/register a license’ button I get the following error:


**FATAL ERROR**

**Index not numeric when loading Digium Product**
Trace Back

/var/www/html/admin/modules/digiumaddoninstaller/functions.inc.php:700 die_freepbx()
  [0]: Index not numeric when loading Digium Product

/var/www/html/admin/modules/digiumaddoninstaller/functions.inc.php:544 digiumaddons_register->load_product()
  [0]: 

/var/www/html/admin/modules/digiumaddoninstaller/page.digiumaddons.php:132 digium_addons->register_load_product()
  [0]: 

/var/www/html/admin/config.php:498 include()
  [0]: /var/www/html/admin/modules/digiumaddoninstaller/page.digiumaddons.php

We’ve tried a fresh install twice now with the same results, removed the modules and added them back in, tried previous versions of the digium modules, all with the same outcome. Would love to hear some ideas on what this little issue is and thoughts on how to solve this. It’s making some folks around here crazy!

Thanks in advance for any assistance!

Howdy,

From the FreePBX Module Admin page, what version of the Digium Add-ons Installer are you using?

Good day malcolmd,

Thanks for the reply! The Digium Add-on version is: 2.11.0.10

Thanks again!

Was looking through the logs and found this… may help point to the issue perhaps… Anyone have any guesses what could cause this? I have several other deployments but this is the first time i’ve run into this issue.

[2015-Apr-23 00:15:14] [PHP-NOTICE] (/var/www/html/admin/modules/digium_phones/functions.inc.php:28) - Undefined variable: amp_conf
[2015-Apr-23 00:15:14] [PHP-NOTICE] (/var/www/html/admin/modules/digium_phones/views/rnav.php:4) - Undefined index: digium_phones_form
[2015-Apr-23 00:15:14] [PHP-NOTICE] (/var/www/html/admin/modules/digium_phones/views/rnav.php:29) - Undefined index: digium_phones_form
[2015-Apr-23 00:15:14] [PHP-NOTICE] (/var/www/html/admin/modules/digium_phones/views/rnav.php:33) - Undefined index: digium_phones_form
[2015-Apr-23 00:15:14] [PHP-NOTICE] (/var/www/html/admin/modules/digium_phones/views/rnav.php:37) - Undefined index: digium_phones_form
[2015-Apr-23 00:15:14] [PHP-NOTICE] (/var/www/html/admin/modules/digium_phones/views/rnav.php:41) - Undefined index: digium_phones_form
[2015-Apr-23 00:17:20] [PHP-WARNING] (/var/www/html/admin/modules/digiumaddoninstaller/functions.inc.php:498) - file_get_contents(http://downloads.digium.com/pub/telephony/addons.json): failed to open stream: HTTP request failed!
[2015-Apr-23 00:17:20] [PHP-WARNING] (/var/www/html/admin/modules/digiumaddoninstaller/functions.inc.php:251) - Invalid argument supplied for foreach()
[2015-Apr-23 00:17:20] [FATAL] (digiumaddoninstaller/functions.inc.php:700) - die_freepbx(): Index not numeric when loading Digium Product

Did you installation complete correctly? That’s certainly not a good error. I’m currently using version 6.12.65-27, obtained by:
cat /etc/schmoze/pbx-release

of the distribution. I’m also using current versions of all FreePBX modules, including 2.11.0.10 of Digium Addons and 2.11.2.3 of Digium Phones Config. And, for me, all is well.

Also, do you have unfettered Internet access? The module will attempt to contact Digium’s registration server in order to determine the categories for which it needs to gather information, beyond the key itself.

Cheers

Good day malcolmd,

That’s the odd thing, there have been no errors during install at all. I’ve re-installed the Digium modules several times, even downgraded them to previous releases and the same issue persists. All the other modules are current as well. The part that’s blowing my mind is that i’ve even formatted and re-loaded from from scratch using both the original ISO as well as the most current ISO available and we still get stuck on the same Index not numeric when loading Digium Product error. It’s really baffling and i’m a bit stumped as to where to go next.

Internet connection is solid, I was hoping that wasn’t the case as I could fix that issue, but it’s a pretty solid link (not that it’s a bad thing to have a good connection for a change). I have three identical servers in my office that i’ve tried duplicating the issue on and have not been able to do so. It feels like it could be a hardware issue as the issue is consistent despite the software I put on it. But i’m weak on the software side of the spectrum and it seems odd to me that if it was a hardware issue, why would it only be with a certain module (NOTE: I did find that the server was timing out when bringing up the ‘System Admin>Updates’ page in the GUI).

Do you know if it’s possible to register the DPMA module from the CLI?

Thanks again for your time and comments!

Cheers,

Yes, registration can be done via the CLI:
https://wiki.asterisk.org/wiki/display/DIGIUM/DPMA+Installation

Cheers