Unable to register 7960G

Hi All, hope someone here can help me. I have setup asterisk and it appears to be working great using softphones, but I’m trying to get some 7960G’s working, but I’m failing. I’ve been playing with this for days, and no luck, I can’t make / receive any calls on the 7960 (either internal or external) but the softphones work fine (using the same accounts).
The phones (soft and 7960) and the asterisk server are all on the same LAN / subnet.

Please can you have a look at my config to see what I’m doing wrong?

SIPDefault.cnf

image_version: P0S3-08-12-00
proxy1_address: "192.168.1.18"            ; Can be dotted IP or FQDN
proxy2_address: ""              ; Can be dotted IP or FQDN
proxy3_address: ""              ; Can be dotted IP or FQDN
proxy4_address: ""              ; Can be dotted IP or FQDN
proxy5_address: ""              ; Can be dotted IP or FQDN
proxy6_address: ""              ; Can be dotted IP or FQDN
proxy_register: 1;
# Proxy Server Port (default - 5060) 
proxy1_port:"5060" 

nat_enable: 0
messages_uri:   "99"
phone_password: "cisco" ; Limited to 31 characters (Default - cisco)
sntp_mode: unicast
sntp_server: "192.168.1.16"
time_zone: "GMT" ; assuming you're in GMT
time_format_24hr: 1 ; to show the time in 24hour format
date_format: "D/M/Y"  ; format you would like the date in
dial_template: dialplan


here is the cnf file for one of the mac's of the phones

Code: Select all
# SIP Configuration Generic File (start)

# Line 1 Settings
line1_name: "97"             ; Line 1 Extension\User ID
line1_displayname: "The Canteen"      ; Line 1 Display Name
line1_shortname: "Canteen"        ; Line 1 Shortname 
line1_authname: "97"         ; Line 1 Registration Authentication
line1_password: "password12"   ; Line 1 Registration Password

# Line 2 Settings
#line2_name: "can"             ; Line 2 Extension\User ID
#line2_displayname: "can"      ; Line 2 Display Name
#line2_shortname: "can"        ; Line 2 Shortname 
#line2_authname: "Canteen"         ; Line 2 Registration Authentication
#line2_password: "password12"         ; Line 2 Registration Password

# Line 3 Settings
#line3_name: ""             ; Line 3 Extension\User ID
#line3_displayname: ""      ; Line 3 Display Name
#line3_shortname: ""        ; Line 3 Shortname 
#line3_authname: ""         ; Line 3 Registration Authentication
#line3_password: ""         ; Line 3 Registration Password

# Line 4 Settings
#line4_name: ""             ; Line 4 Extension\User ID
#line4_displayname: ""      ; Line 4 Display Name
#line4_shortname: ""        ; Line 4 Shortname 
#line4_authname: ""         ; Line 4 Registration Authentication
#line4_password: ""         ; Line 4 Registration Password

# Line 5 Settings
#line5_name: ""             ; Line 5 Extension\User ID
#line5_displayname: ""      ; Line 5 Display Name
#line5_shortname: ""        ; Line 5 Shortname 
#line5_authname: ""         ; Line 5 Registration Authentication
#line5_password: ""         ; Line 5 Registration Password

# Line 6 Settings
#line6_name: ""             ; Line 6 Extension\User ID
#line6_displayname: ""      ; Line 6 Display Name
#line6_shortname: ""        ; Line 6 Shortname 
#line6_authname: ""         ; Line 6 Registration Authentication
#line6_password: ""         ; Line 6 Registration Password

# SIP Configuration Generic File (stop)

# Phone Label (Text desired to be displayed in upper right corner)
phone_label: "The Canteen  " ; add a space at the end, looks neater

The config is copying to the phone as the labels are updating, but there is a little cross next to the phone symbol next to the line button. And is asterisk I can see IP Phones online is only showing the softphones.