Unable to receive new calls after internal or external transfer

Are they dynamic agents? If you made the change after they logged in, then you have to log them out and back in for the changes to apply.

Yes, well it worked for us too a while ago. But not anymore.

No they are not. At least, the setting “Restrict Dynamic Agents” is set to ‘no’. Does this affect the outcome of our current problem?

How do agent log in? What do they do/press? What does the login entry look like in Reports>Asterisk Info>Queues?

The agents login via Bria, they press ‘3000’, after that they select ‘login/logout’ and position. So login and being the first in the queue would be: call 3000, press 1 for login, press 1 for position 1 and then hang up.

I am not sure what you would get out of this, but this is what the “Reports > Asterisk Info > Queues” says:

2100 has 0 calls (max unlimited) in ‘ringall’ strategy (6s holdtime, 198s talktime), W:0, C:3, A:0, SL:100.0%, SL2:100.0% within 300s
Agents 2 [Bria] (Local/[email protected]/n from hint:[email protected]) with penalty 2 (ringinuse disabled) (dynamic) (Not in use) has taken no calls yet
Agent 1 (Local/[email protected]/n from hint:[email protected]) with penalty 1 (ringinuse disabled) (dynamic) (in call) (In use) has taken 3 calls (last was 2405 secs ago)
No Callers

default has 0 calls (max unlimited) in ‘ringall’ strategy (0s holdtime, 0s talktime), W:0, C:0, A:0, SL:0.0%, SL2:0.0% within 0s
No Members
No Callers

Based on the asterisk info it does look like the agents are indeed dynamic. Do these agent logout everyday, or do they never logout?

Also can you try a test by changing an agent to static and confirm you have the same transfer problem?

Well, what happens if they dial instead *45 to login/out. Does it work OK?

They are dynamic, yes. They login and out every day.

We will consider to change it to static, but we need to see what the consequences are.

When we call *45, the agent is logged out. But not logged in.

Are they set as Dynamic Members?

Nothing to consider yet, performing this test helps narrow what the issue could be. Are you able to test it out and report back if it also fails?

We changed the settings to static and the transfer did work. However, with a static agent we do not have the option to login/logout and change position. So that is not what we want. Therefore we changed the ‘skip the agent when busy’ to ‘Yes’ (before was 'yes (plus ring in use =no). If now a colleague wants to make an external phone call (not a transfer), he or she need to log out so when a new call comes in, it does not disturb to outgoing call. The only downside from this is the login / logout, but since we don’t call that much externally, this should be the work around.

It seems to be “fixed” for us for now. Thanks for all the help.

If you go to Reports>Asterisk Info>Queues can you have one agent as static and one logged in as dynamic and compare the entry for each agent (how are they different)?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.