Unable to install amportal because of known bug FREEPBX-6822

I’m trying to install the latest freepbx and asterisk according to the instructions here:


I have Ubuntu 14.04 and have completed all steps up to installing freepbx. When I run the command:

I get errors:

[code]Please wait…
/usr/local/sbin/amportal: line 47: [FATAL]: command not found

/var/lib/asterisk/bin/freepbx_engine: line 98: [FATAL]: command not found
astrundir in ‘/etc/asterisk’ is set to but the directory
does not exists. Attempting to create it with: 'mkdir -p ’

mkdir: missing operand
Try ‘mkdir --help’ for more information.
Attempt to execute 'mkdir -p ’ failed with an exit code of 1
You must create this directory and the try again.

This error text is listed in the bug report FREEPBX-6822 found here:


And appears to be a db connection issue. What the bug report doesn’t specify, and I haven’t been able to find, is how to fix this problem.

Any suggestions on how to proceed?

You need to make sure that the settings in /etc/freepbx.conf allow said mysql user to connect to said database. That is what the “bug” is (which is really not a bug, but more a display issue)

Basically your database permissions are wrong.

Thank you. That was the problem. I’m not sure where I went wrong. I followed the instructions on the page twice with the same result. The password listed in the /etc/freepbx.conf was the default pw and I don’t see a step to update that on the installation instructions page. Perhaps an addition to the instructions would be helpful for others.

Thanks again.

Hi! search directed me to whis thread.
I had same error. And config file was ok.
The reason was in pear DB module.
I had 1.8. Deleted it and installed older 1.7.
Thanks to this guy blog (ekorzhik)