Unable to get Postfix to work

I have the latest distro with the free system Admin Module (6.12.65-26) I am trying to get VM to email to work but constantly get NDR’s. Can someone please give me a step by step? I first tried configuring it in the gui to no avail now I am trying sasl to no avail. What settings should be changed and should not be changed in the gui? I changed the hostname (maybe I shouldn’t have) I tried using the internal server and it fails I try and external (godaddy smtpout.secureserver.net) and it fails. I am ready to go back to my old distro from a few years ago and just restore from backup but i would really like to use this new verison.

Any help would be appreciated

You’ll need to provide more details. see /var/log/maillog
How are your outgoing emails usually delivered ?
Any SMTP relay or directly to destination mailserver/s ?
Does your SMTP mailserver require authentication before accepting email messages ?
Some ISP’s block port 25 by default.
Postfix is not usually difficult to configure. See /etc/postfix/main.cf