Unable to enable DTLS in estension advance menru


(Mohsin) #1

I am trying to create new chansip extension for sipml5. after new updates when i try to enable DTLS from advance settings it gives me following message.

“Please enable DTLS for Media Encryption field first before enabling DTLS parameters”

before update all extensions were created easily with this issue and working as well. now after update old extensions are still working but new extensions are receiving this error.

I can not find any option where i can enable DTLS for media encryption.
can anyone help how to solve this issue.

I even reinstalled the whole server after adding ssl certificate i tried to create extension still same message.

I am using Freepbx 15 latest version


(Alex) #2

Try adding a pjsip extension with dtls settings enabled and converting to chan_sip


(Kapil Gupta) #3

Please enable DTLS for Media encryption parameter under Extension edit -> Advanced section.


(Mohsin) #4

Yes I just did.

  1. if we create pjsip extension it gives forbidden error loging in.
  2. I try chansip i was able to login successfully but unable to make call(becasue of DTLS)
  3. if we create pjsip and after enableing dtls we change to chansip it still says for bidden
    4 if we creat chansip loging successfully but to enable dtls we change to pjsip after successfully adding dtls we go back to chansip it says forbidden again(i did not even change the password)

(Mohsin) #5

this is for pjsip i want to enable on chansip. there no field in chansip for media encryption


(Matthew Fredrickson) #6

chan_sip is not a good pathway forward (technologically) with webrtc. None of the most recent webrtc fixes and improvements in Asterisk have gone into chan_sip, as well as chan_sip is marked as deprecated in Asterisk now.

It’d be better to figure out what’s going on with chan_pjsip.

Can you post the output of pjsip set logger on when you try to register/make-a-call with chan_pjsip so we can better figure out what might be happening?


(Dave Burgess) #7

@methenothing - as we move forward, this answer is going to become more and more true. With the deprecation of Chan-SIP and the inexorable drive to improve the system, more and more features are just going to get left behind.

I hope that you’ll join us in this improvement process by posting what you end up getting working so that other can benefit from your experience and hard work.


(Amardeep Kashyap) #8

error getting on registration : == Wrong password
how to fix this.

WebSocket connection from ‘106.223.196.235:35085’ for protocol ‘sip’ accepted using version ‘13’
[2020-06-18 08:51:19] NOTICE[24813]: chan_sip.c:29029 handle_request_register: Registration from ‘“1006” sip:1006#XXXXXXXX’ failed for ‘106.223.196.235:35085’ - Wrong password
chan_sip is deprecated , pjsip is not register on webrtc.