Unable to drag & drop backup to be restored

CentOS 6.6 box running FreePBX 12.0.70 & Certified Asterisk 13.1 (Cert 2).

I am attempting to restore a backup through the Backup & Restore module by dragging the “Full Backup” template to the “Drop Here” area. However, nothing happens.

I have tried various browsers and various OS’s. They behave the same. I also confirmed that my JavaScript is working.

Any ideas?

Thanks much,


I’m pretty sure that NEVER worked, and I’m probably going to remove it. Just select the things you want to restore.

Ah ok. I wasn’t positive what the right items to restore were which is why I was eyeing the “Full Backup” template.

That said, I have a backup from an Asterisk 1.8 + FreePBX 2.10 server. I wanna migrate to newer versions. Should I be able to successfully import this to the Asterisk 13 + FreePBX 12 instance? Or do I need to start from scratch?

If I can restore, I should select everything?

The best way to do that is to use the upgrade tools to go from 2.10 to 12. If you go to module Admin, you can install the Upgrade tool to take you from 2.10 to 2.11, do all the updates there, and then go from 2.11 to 12. Once you’re at 12, you can then restore to another 12 machine.

Restoring between versions is hard. Restoring between cpu architectures is hard prior to asterisk 11, as well, but doable.