Unable to do any updates as of today

I’m on distro Today I was updating servers, including FreePBX.
Usually this is no problem. Today, every update throws an error. Asterisk system update, and module updates.

The truncated error is in red and just keeps flashing every second.
I’ve tried rebooting the server, it did not clear the problem.

RPM command errored, tried to run '/usr/bin/rpm -q --queryformat “%{VERSION}.%{RELEASE}\n” alsa-lib.x86_64 audit.x86_64 audit-libs.x86_64 authconfig.x86_64 bash.x86_64 bind-libs.x86_64 bind-libs-lite.x86_64 bind-license.noarch bind-utils.x86_64 binutils.x86_64 biosdevname.x86_64 bluez-libs.x86_64 boost-filesystem.x86_64 boost-program-options.x86_64 boost-system.x86_64 boost-thread.x86_64 btrfs-progs.x86_64 ca-certificates.noarch cairo.x86_64 chkconfig.x86_64 chrony.x86_64 copy-jdk-configs.noarch cpio.x86_64 cpp.x86_64 cronie.x86_64 cronie-noanacron.x86_64 cryptsetup.x86_64 cryptsetup-libs.x86_64 cups-libs.x86_64 curl.x86_64 cyrus-sasl-lib.x86_64 cyrus-sasl-plain.x86_64 device-mapper.x86_64 device-mapper-event.x86_64 device-mapper-event-libs.x86_64 device-mapper-libs.x86_64 device-mapper-multipath.x86_64 device-mapper-multipath-libs.x86_64 device-mapper-persistent-data.x86_64 dhcp-common.x86_64 dhcp-libs.x86_64 dmidecode.x86_64 dnsmasq.x86_64 dos2unix.x86_64 dracut.x86_64 dracut-network.x86_64 e2fsprogs.x86_64 e2fsprogs-libs.x86_64 efibootmgr.x86_64 efivar-libs.x86_64 elfutils-libelf.x86_64 elfutils-libs.x86_64 ethtool.x86_64 fcoe-utils.x86_64 fipscheck.x86_64 fipscheck-lib.x86_64 firewalld.noarch firewalld-filesystem.noarch fontconfig.x86_64 freeradius.x86_64 freetype.x86_64 fuse.x86_64 fuse-libs.x86_64 gcc.x86_64 gcc-c++.x86_64 gdk-pixbuf2.x86_64 gettext.x86_64 gettext-libs.x86_64 gfs2-utils.x86_64 ghostscript.x86_64 glib2.x86_64 glibc.x86_64 glibc-common.x86_64 glibc-devel.x86_64 glibc-headers.x86_64 glibmm24.x86_64 gmp.x86_64 gnutls.x86_64 gobject-introspection.x86_64 grep.x86_64 grub2.x86_64 grub2-tools.x86_64 grubby.x86_64 gzip.x86_64 harfbuzz.x86_64 httpd.x86_64 httpd-tools.x86_64 hwdata.x86_64 initscripts.x86_64 iproute.x86_64 iprutils.x86_64 ipset.x86_64 ipset-libs.x86_64 iptables.x86_64 iptables-services.x86_64 iputils.x86_64 irqbalance.x86_64 iscsi-initiator-

I had that too. Just do a “yum update” from the CLI.


Sounds like this thread

and this one

(which I decided not to reply to for reasons I won’t get into…)

Just do

yum update

from the command line…

Looks like System Admin is having trouble processing the list of updates to apply or something like that, doing the update manually bypasses the problem… It’s also possible it might be the results of rpm package conflicts, something which was not possible previously with FreePBX 13…

I think (I hope) that a ticket was opened about this problem…

Good luck and have a nice day!


Did you upgrade from 13? If so you may have some old packages still sitting on your system that need removed

I had these left over causing the problem.

Transaction check error:
  file /usr/lib/firmware/ql2400_fw.bin from install of linux-firmware-20170606-56.gitc990aae.el7.noarch conflicts with file from package ql2400-firmware-7.03.00-1.el6_5.noarch
  file /usr/lib/firmware/ql2500_fw.bin from install of linux-firmware-20170606-56.gitc990aae.el7.noarch conflicts with file from package ql2500-firmware-7.03.00-1.el6_5.noarch

This removed them.

yum remove ql2500-firmware
yum remove ql2400-firmware

Then a manual update will work.

yum update

The first linked thread had a ticket opened, so I did not bother to open one for my thread (the second one you linked).

Then why bother to even say this?

OK, a ticket was opened


but it was closed and refers back to the thread I referred to earlier

ie System updates gets exception even after reboot

and this specific post if you have dependency problems:

Good luck and have a nice day!


1 Like

Negative. This was a clean install from the 14 ISO. Updates worked perfectly up until this week.

You can have this problem even when it is not an upgrade…

You have a chance to have additional problems when it is an upgrade…

(Some old FreePBX 13 distro package could still be there and cause update problems…)

Did a

yum update

from the command line fixed things?

Good luck and have a nice day!


Yes, it is working. I am updating now, thank you.

Yes we had a issue with using the GUI to update yum packages. You needed to update your modules first for a bug in FreePBX framework that would keep yum packages from updating to EL7.4 from the 7.3 you were based on before.