Unable to Dial In On Grandstream

Hello, I acquired a Grandstream gxw4104 and am having problems getting it to pass a call to my PBX. I can dial out without any problems but inbound always tells me “No Matching Endpoint” and then “Failed to Authenticate” in the CLI.

I followed the instructions at https://wiki.freepbx.org/display/FOP/Configuring+a+Grandstream+GXW-410X+Device+to+act+as+an+FXO+Gateway but it doesn’t mention the inbound trunk settings. I have left them blank and filled them in and it doesn’t seem to make any difference.

I do have an inbound and outbound route and can dial 7777 and have it route properly so I believe my inbounds are correct. My logs are as follows (number changed obviously):

[2019-08-18 17:18:00] NOTICE[17575]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘“DENVER CO” sip:[email protected]’ failed for ‘10.1.200.238:5060’ (callid: [email protected]) - No matching endpoint found
[2019-08-18 17:18:00] NOTICE[17575]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘“DENVER CO” sip:[email protected]’ failed for ‘10.1.200.238:5060’ (callid: [email protected]) - No matching endpoint found
[2019-08-18 17:18:00] NOTICE[17575]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘“DENVER CO” sip:[email protected]’ failed for ‘10.1.200.238:5060’ (callid: [email protected]) - Failed to authenticate
[2019-08-18 17:18:00] NOTICE[17575]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘“DENVER CO” sip:[email protected]’ failed for ‘10.1.200.238:5060’ (callid: [email protected]) - No matching endpoint found
[2019-08-18 17:18:00] NOTICE[17575]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘“DENVER CO” sip:[email protected]’ failed for ‘10.1.200.238:5060’ (callid: [email protected]) - Failed to authenticate

The wiki article refers to a chan_sip trunk. With default settings in your PBX, Bind Port for chan_sip is 5160, so in your Unconditional Call Forward settings in the GXW you should change
Sip Destination Port: ch1-4:5060
to
Sip Destination Port: ch1-4:5160

If no luck, post another log with the new setting.

That seems to have done the trick. Thank you very much for the help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.