Unable to connect to servers from URLs provided

Downloading and Installing userman
Downloading userman
Error(s) downloading userman:
Unable to connect to servers from URLs provided: http://mirror1.freepbx.org/modules/packages/userman/userman-,http://mirror2.freepbx.org/modules/packages/userman/userman-
Updating Hooks…Done

I’m seeing this issue on more than just one module. I attempted to upgrade 3 modules and all returned with the same response.

I am also seeing other issues but will enter each one separately. Are we sure this version is stable? Are there multiple definitions of stable? Asking for a friend.

This is a new install and went into production yesterday. I have verified this is not a DNS issue either from the VoIP server or the workstation connected to the GUI.

Make sure the FreePBX firewall is permitted to send/receive traffic from those sites.

I can ping both and get responses.

It must be the app. I can call the URL from the command line of the PBX and it downloads the file.

wget -p http://mirror1.freepbx.org/modules/packages/userman/userman-
–2017-07-06 20:02:25-- http://mirror1.freepbx.org/modules/packages/userman/userman-
Resolving mirror1.freepbx.org (mirror1.freepbx.org)…
Connecting to mirror1.freepbx.org (mirror1.freepbx.org)||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 369551 (361K) [application/octet-stream]
Saving to: ‘mirror1.freepbx.org/modules/packages/userman/userman-’

100%[======================================>] 369,551 1.67MB/s in 0.2s

2017-07-06 20:02:25 (1.67 MB/s) - ‘mirror1.freepbx.org/modules/packages/userman/userman-’ saved [369551/369551]

FINISHED --2017-07-06 20:02:25–
Total wall clock time: 0.4s
Downloaded: 1 files, 361K in 0.2s (1.67 MB/s)

I found a workaround.

Selected all updates I wanted and grabbed their URL from the error notice.
Opened another tab and downloaded each of them individually.
Select Manage Local Modules
Select Upload Modules
Select Drop down Upload (From Hard Disk)
Select Choose File
Select the file
Select Upload (From Hard Disk) button
Once uploaded, you can then select the files(s) from the list and choose Update from x to x version or Install if not installed
Select Process
Select Confirm

That works. I also found in Asterisk settings you can select to use wget by default and that may work. I’m not blocking anything out through the firewall. It must be the way it’s trying to connect vs wget.