Unable to call out from the Asterisk platform

I have setup a Trixbox and while I am able to receive calls from within the trixbox and to receive calls from outside (PSTN & GSM). I am unable to make any calls to the outside. For clarification I have attached my zaptel and zapata files here below. I appreciate all help that I can get on this issue.

Span 1: WCT1/0 “Wildcard TE122 Card 0” (MASTER) HDB3/CCS/CRC4 RECOVERING


termtype: te


;If you connect to a hicom PBX set your ISDN Numbering Plan Identifier to unknown.
; signalling=fxo_ks
group = 1
channel => 1-15
channel => 17-31

Do I need to create another channel within zapata to enable outbound dialing via the Zap interface?


since you are using trixbox (but you don’t say which version) they have a script that you should run to configure zaptel properly.

In 1.2 it was called genzaptelconf, once that was done you needed to reboot the box so that it loaded the configured drivers and things started to work. I don’t know if they changed the name of it going forward in newer versions but have you run that script yet and rebooted?

a good manual to take a look at is trixbox without tears 2. You’ll find it on the web in many locations and it walks you through the whole process.

I checked the manual, haven’t been able to figure out anything yet from it. Did run the genzaptelconf though, didn’t make any difference.

Since you asked for the version I checked it out and it is trixbox CE current release is I have updated everything on the server with the newest packages.


Well to start you are missing two lines to start in your zaptel.conf file the parameters you are missing are: loadzone = and defaultzone = . They default to us if they are missing and based on your config you are not in the US so that can cause problems.

At the linux command line type ztcfg -vv

This should give you a output with all the channels listed, if not the drivers are not loading the configuration correctly. Asterisk only see’s what the privers say is is available and FreePBX only see’s what asterisk says it see’s.

Just didn’t copy those lines, they are in the zaptel.conf file

Global data

loadzone = se
defaultzone = se

Here’s the output from the ztcfg -vv command:
[trixbox1.localdomain etc]# ztcfg -vv

Zaptel Version: 1.4.11
Echo Canceller: OSLEC

SPAN 1: CCS/HDB3 Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: Clear channel (Default) (Slaves: 01)
Channel 02: Clear channel (Default) (Slaves: 02)
Channel 03: Clear channel (Default) (Slaves: 03)
Channel 04: Clear channel (Default) (Slaves: 04)
Channel 05: Clear channel (Default) (Slaves: 05)
Channel 06: Clear channel (Default) (Slaves: 06)
Channel 07: Clear channel (Default) (Slaves: 07)
Channel 08: Clear channel (Default) (Slaves: 08)
Channel 09: Clear channel (Default) (Slaves: 09)
Channel 10: Clear channel (Default) (Slaves: 10)
Channel 11: Clear channel (Default) (Slaves: 11)
Channel 12: Clear channel (Default) (Slaves: 12)
Channel 13: Clear channel (Default) (Slaves: 13)
Channel 14: Clear channel (Default) (Slaves: 14)
Channel 15: Clear channel (Default) (Slaves: 15)
Channel 16: D-channel (Default) (Slaves: 16)
Channel 17: Clear channel (Default) (Slaves: 17)
Channel 18: Clear channel (Default) (Slaves: 18)
Channel 19: Clear channel (Default) (Slaves: 19)
Channel 20: Clear channel (Default) (Slaves: 20)
Channel 21: Clear channel (Default) (Slaves: 21)
Channel 22: Clear channel (Default) (Slaves: 22)
Channel 23: Clear channel (Default) (Slaves: 23)
Channel 24: Clear channel (Default) (Slaves: 24)
Channel 25: Clear channel (Default) (Slaves: 25)
Channel 26: Clear channel (Default) (Slaves: 26)
Channel 27: Clear channel (Default) (Slaves: 27)
Channel 28: Clear channel (Default) (Slaves: 28)
Channel 29: Clear channel (Default) (Slaves: 29)
Channel 30: Clear channel (Default) (Slaves: 30)
Channel 31: Clear channel (Default) (Slaves: 31)

31 channels to configure.

Again, I can call into the platform but I just cannot call from my softphone to the PSTN/GSM network


Have you checked your outgoing dial rules & outbound routes?

The dial rule is simple, 7 digits like this:

So my guess would be that something is wrong with the outbound routes. Just a question of what.

I always get the prompt “Your call cannot be completed as dialed, please check the number and dial again” or “all circuits are busy now, please try your call again later”


Yes, it sounds like you have an outbound routing problem. Make sure your trunk is listed as the top sequence in the outbound route. Also, I’ve never used a pri, but asterisk may be sending the digits too quickly (this happens often with zap hardware). Try adding a wait command (w) before the trunk’s dial rules- for example: w+XXXXXXX

Keep us posted.


there is no need for a wait on the PRI. there is not really dialtone, it grabs a line and just starts using it.

I didn’t realize that, thanks for the info.


Still no solution on my end. I am battling with the problem. I can’t figure out what’s wrong with the setup.

There is one zap trunk setup with the id ZAP/g1, dial rule pretty straight forward just XXXXXXX (seven digits) and caller id hidden (have also tried various numbers).

The outbound route has the same dial pattern as the trunk (XXXXXXX) trunk sequence ZAP/g1

I just don’t see what the problem is and any help would be greatly appreciated.


I figured out what the problem was. I had incorrect zaptel configuration. As can be seen on my first post I had the span configured with crc4 when it shouldn’t be setup with crc4. (span=1,1,0,ccs,hdb3,crc4). That and the need to use a custom trunk setup enabling DAHDI instead of Zap solved the issue at hand. By using “DAHDI/g1/$OUTNUM” as the custom dialout string. I hope this helps someone out there.