Unable to 'Apply Configuration Changes'


I’ve tried to spend a great deal of time reading through already existing threads about this topic, but the suggestions that I have seen and tried did not seem to encompass the circumstances of my issue.

I’m using FreePBX v2.9.0.7 and when attempting viewing the dashboard under ‘Server Status’ it shows that Asterisk is not running and displays ERROR. This of course is preventing me from making changes to things such as Extensions in the Web GUI.

I know that asterisk is running because I am able to access the CLI, use my desk phone and see that the process is running using TOP.

Additionally, I have not attempted to change the default password. I have checked the following files for consistency and they all show the default password in the correct places.


Also, retrieve_conf is returning this to me when I attempt to run it:

Mon, 03 Oct 2011 11:03:38 -0400 - Unable to connect to manager localhost:5038 (111): Connection refused [FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting

Is there anything I can look at or more information I could provide that might help with this issue?

I was able to resolve the condition, the binding address in manager.conf was incorrectly set to an address other than localhost somehow.

Changing the following line fixed this issue:

[general] enabled = yes port = 5038 bindaddr =

Modifying the bindaddr to the setting of corrected the issue.