FreePBX | Register | Issues | Wiki | Portal | Support

Unable to apply config after updating modules


#1

Fresh install, and updating modules - when I apply config I get the following error

exit: 1
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
Exception: Unable to connect to Asterisk through the CLI in file /var/lib/asterisk/bin/retrieve_conf on line 30
Stack trace:

  1. Exception->() /var/lib/asterisk/bin/retrieve_conf:30

(TheJames) #2

is asterisk running?
Is it running as root? (it shouldn’t be)


#3

I do believe its running and not as root - I ran fwconsole chown


(TheJames) #4
asterisk -rx 'core stop now'
fwconsole start

#5

Fixed, how did that happen so I can avoid. Also THANK YOU SOOOOO MUCH!!


(TheJames) #6

always start asterisk through fwconsole start.


#7

Ever since, now whenever I try to check for updated modules it just spins forever - any ideas?


#8

Do you have a content filter?

Maybe try setting:

“Use wget For Module Admin” to YES in Advanced Settings


#9

still no luck :frowning:


#10

Hello,

Im still stuck on this one… its a mystery that it just spins…

Any ideas would be super appreciated!


(Andrew Nagy) #11

use the cli to update:

fwconsole ma upgradeall


#12

That worked!! Thank you :slight_smile:


(JAN) #13

Thanks, me too.