UI Issue


I have the weirdest UI issue that I spent yesterday a couple of hours to resolve.

I am running a Debian lenny 5.0 server with asterisk

I was happily running 2.4 but about 3 months ago we upgraded using the module admin to 2.9.0 right through the versions.

Something happen when we get to 2.9.

Basically the menu on the left (SETUP/TOOLS) is all visible. You can scroll down through all the options. When you click on tools at the top it just scrolls down to ‘Admin’ Freepbx System Status’ etc.

If I make a change it’s impossible to actually apply the changes. The red bar is there but unclickable.

So yesterday I got rid or my /var/www/admin and all the other files belong to freepbx - dropped the asterisk database. Deleted /etc/amportal.conf and deleted /etc/asterisk and ran make samples again from asterisk source.

I then ran stopped asterisk ran start_asterisk start. Created the asterisk db and populated and ran install_amp

eVerything runs fine but I still have the same damn issue… Nothing is clickable and all other UI issues are there.

I tried to do this a couple of more times but tried some other things and always everything installs fine but always the issue with the UI.

I tried 2.10 beta using same method, same UI issue.

I installed 2.4 and issue is gone!

I upgrade through to 2.7 and issue comes back.

It becomes impossible to click submit to upgrade modules so I used the command line to upgrade the pbx back to 2.9 (as this is the version of my backups)

Try to restore backup. Can’t click on anything etc… Pull hair out and shout at neighbour.

I have a look in chrome deubug and notice:

Uncaught ReferenceError: jQuery is not defined
(anonymous function)jquery.cookie.js:56
jquery-ui-1.8.x.min.js:18Uncaught ReferenceError: jQuery is not defined
jquery.dimensions.js:581Uncaught ReferenceError: jQuery is not defined
jquery.toggleval.3.0.js:104Uncaught ReferenceError: jQuery is not defined
interface.dim.js:79Uncaught ReferenceError: jQuery is not defined
config.php:183Uncaught ReferenceError: $ is not defined
config.php:35Uncaught ReferenceError: body_loaded is not defined
(anonymous function)config.php:35

I grep for body_loaded and notice its in libfreepbx.javascripts.js

Rename this file to libfreepbx.javascripts.js.1 and the UI works again!

Restore backup check everything - all ok - sleep.

Just took a look now and issue is back nothing clickable etc…

I’m going to wipe this machine but would just love to know if anyone could shed any light onto what is causing this?

Cheers in advance.