UCP to add voicemail recordings - FreePBX 14.0.1

I just installed two different installs on Vultr using the ISO. Both are 14.0.1 configs.

Everything is fine but when I go to the UCP to upload .wav files for Voicemail I get a “There was an error. See the console log for more details”

I am lost.

I uploaded a .wav for the IVR and that went fine.
I uploaded two .wav for announcements and that went fine.

This seems specific to UCP.

To make sure I was not crazy, I went into the user management -> user -> UCP -> Voicemail and made sure everything was set to yes. I also tried .mp3, .wav, .m4a to make sure it was not a conversion issue.

One of the systems, I upgraded all the modules in the admin section, the other is default.

Any clues?

Solved it.

This was done because I was just going to give up and upload the recorded files via SCP.

I found an article that stated, “The directory structure is NOT made until you login into the mailbox.”

Once I logged into the mailbox (*98extension is your friend,) I was able to upload the files via the UCP

I recently did a PIAF install which also had UCP and was able to upload without logging into the mailbox. Perhaps this is a bug in that when the voicemailbox is created it doesn’t create the directory structure?