UCP super slow after upgrading from ver 13 to 15

configuration
Tags: #<Tag:0x00007f7026fe9b90>

(Roel Sarceno) #1

UCP 15.0.16.18
PBX Version:15.0.16.75
PBX Distro:12.7.6-2002-2.sng7
Asterisk Version:13.32.0

I have three servers that are identically setup.
One of the Server UCP is Too slow (the other two are fine)
The server that was slow even has a SSD
It’s slow regardless of which browser. Also tried different ISP and computerdifferent remote ISP

Getting the login prompt is quick
After you enter the credentials, it take 3 to 5 minutes to load the main screen
It takes another 3 to 5 minutes after you click on the plus sign to display Add Widget

Before it display the main screen or Add Wiidget, I get a warning Page unresponsive. I have to click continue /OK once or twice

The issue is only with UCP. Everything else has normal response time.

I read someone recommending to disable System RSS and UCP RSS
I empty the fields hoping the will disable it.

UCP_Err.log
6039 2020-09-11 16:38 -07:00: Error: ENOENT: no such file or directory, stat ‘/var/www/html/admin/modules/ucp/node/lib/public/index.html’
6040 2020-09-11 23:21 -07:00: { Error: MySQL server has gone away code: 2006 }
6041 2020-09-11 23:21 -07:00: There was an error with MySQL Connection
6042 2020-09-12 07:21 -07:00: { Error: MySQL server has gone away code: 2006 }
6043 2020-09-12 07:21 -07:00: There was an error with MySQL Connection
6044 2020-09-12 09:42 -07:00: Error: ENOENT: no such file or directory, stat ‘/var/www/html/admin/modules/ucp/node/lib/public/index.html’
6045 2020-09-12 15:21 -07:00: { Error: MySQL server has gone away code: 2006 }
6046 There was an error with MySQL Connection
6047 2020-09-12 19:47 -07:00: Error: ENOENT: no such file or directory, stat ‘/var/www/html/admin/modules/ucp/node/lib/public/index.html’
6048 2020-09-12 23:21 -07:00: { Error: MySQL server has gone away code: 2006 }
6049 There was an error with MySQL Connection

ucp_out-log
12025 2020-09-12 23:21 -07:00: { AMPDBUSER: ‘freepbxuser’,
12026 AMPDBPASS: ‘xxxxxxxxx’,
12027 AMPDBHOST: ‘localhost’,
12028 AMPDBNAME: ‘asterisk’,
12029 AMPDBENGINE: ‘mysql’,
12030 datasource: ‘’ }
12031 2020-09-12 23:21 -07:00: Starting FreePBX…2020-09-12 23:21 -07:00: FreePBX is Ready!
12032 Asterisk version is: 13.32.0
12033 2020-09-12 23:21 -07:00: Loading all UCP Modules…
12034 Loading…conferencespro.js
12035 Loading…ucphelloworld.js
12036 Loading…xmpp.js
12037 2020-09-12 23:21 -07:00: Done!
12038 2020-09-12 23:21 -07:00: Server up and running at 8001 port
12039 Secure Server up and running at 8003 port

Someone post “UCP utilizes significant CPU cycles” but they was no useful reply

Appreciate any info.


(Roel Sarceno) #2

I’m thinking of reinstalling UCPnode.
I search the forum and found 4 possible solutions

Option 1:
fwconsole ma downloadinstall ucpnode --tag=x.x.x.x

Option 2:
fwconsole ma upgrade ucpnode --edge

Option 3:
fwconsole ma downloadinstall ucp --force

Option 4:
yum remove npm
yum install nodejs
fwconsole ma uninstall ucpnode
fwconsole ma remove ucpnode
fwconsole ma download ucpnode
fwconsole ma install ucpnode

I appreciate any info on what the best option to reload the could fixed the slowness issue.

Thanks