UCP Phone not working


FreePBX Distro: 12.7.4-1804-1.sng7
Asterisk: 14.7.5

We are using a certificate from GoDaddy
Ports: 443, 4443 & 4443 are open (for trusted addresses only.)

Phone says registered, but i cannot place or answer calls.
It rings when i have a incoming call, but it stops ringing when i click answer and nothing happens. Desk phone continues to ring, and caller hears the same.

See attached image - Console log:

06:01:37 is when i tried to place a call.
06:02:34 is when it started ringing - incoming call
06:02:39 is when i pressed answer.

Anyone with a GoDaddy certificate has this working? or am i doing something wrong?


Never tried a godaddy certificate but the Phone ONLY works when using HTTPS:// and not HTTP:// . Check that apache is using that certificate in system-admin -> https-setup

Yep. HTTPS is on. And obviously used with with HTTPS.

Try making the UCP/WebRTC ports as open as possible on the firewall then retest, can adjust later. It will let you attempt calls with the wrong permissions but will just kill the audio/connection.

This and the standard FreePBX ports are fully open from where i test this.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.