UCP issues

Greetings to all.

When i click on a phone number to originate call this comes up.
image

After pressing initiate i get this:
image

But when i press originate, nothing happens…
Same issue over http or https, i cannot find on the wiki any settings for this that needs to be changed.

Anyone?

Thanks

EDIT: I see there’s already a report in the issue tracker: https://issues.freepbx.org/browse/FREEPBX-16566

Does anyone have UCP in FreePBX 14 completley working?

  • I see now that the Phone is UCP is registering successfully over https, it rings when i have a incoming call but no caller information other than it gives me a button to answer the incoming call. When i click to pickup the call nothing happens… same when i try to place a call…

  • I created a new contact group, tried adding a contact, i got an error "There was an error. See the console log for more details"
    Console log:

      Uncaught TypeError: Cannot read property 'push' of undefined
          at HTMLInputElement.<anonymous> (jsphp_e062e19f8ed3a714dfa91c6efc072ce9.js?load_version=v14.0.2.1:1595)
          at Function.each (jquery-3.1.1.min.js?load_version=v14.0.2.1:2)
          at jQuery.fn.init.each (jquery-3.1.1.min.js?load_version=v14.0.2.1:2)
          at HTMLButtonElement.<anonymous> (jsphp_e062e19f8ed3a714dfa91c6efc072ce9.js?load_version=v14.0.2.1:1589)
          at HTMLButtonElement.dispatch (jquery-3.1.1.min.js?load_version=v14.0.2.1:3)
          at HTMLButtonElement.q.handle (jquery-3.1.1.min.js?load_version=v14.0.2.1:3)
    
  • When forwarding a voicemail in UCP FreePBX 13 you started typing a name or an extension number and it populated a list with all matching extensions, this doesn’t happen.

I appreciate if anyone can please help out.

Thanks

I see this is a “feature request” https://issues.freepbx.org/browse/FREEPBX-16556

OK… The issue seems to be with the email field, if i create a contact and leave the email field blank, i am able to save the contact. Once i add any text in the email field, even when i modify a already saved contact i get the mentioned error. EDIT: https://issues.freepbx.org/browse/FREEPBX-16656

Now this… When logging in to UCP i’m getting two errors
"Unable to connect to the UCP Node Server because: ‘Error: xhr poll error’ " and then for a second i get this: “Unable to authenticate with the UCP Node Server” and back to the first error.

I tried to restart UCP Node, Restart fwconsole, rebooted PBX… no luck.

UCP_Out.log
2018-01-18 08:19 -05:00: Loading all UCP Modules…
Loading…conferencespro.js
Loading…ucphelloworld.js
Loading…xmpp.js
2018-01-18 08:19 -05:00: Done!
Server up and running at 8001 port
Secure Server up and running at 8003 port

UCP_Err.log
{ Error: MySQL server has gone away code: 2006 }
There was an error with MySQL Connection
There was an error with Asterisk Manager Connection

Can anyone help me troubleshoot this?

Thanks

Bump.

Can anyone help me how to fix this - remove the errors? Or at least how to completely delete UCP config and start again from scratch?

PS. I started getting these error alerts after i created a new group in User Manager.

Thanks

Bump…

We really need to fix this… anyone has an idea how we can maybe delete all existing UCP config and start again?

I removed userman & ucp, reinstalled them, no errors so far.

Just an update…
Contact issue was fixed.
Originate issue was fixed.
If you have the latest UCP edge you should be good.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.