UCP Chat Client

I have the UCP and the UCP Node Server installed and running but I am unable to bring up the native UCP chat client, the link in contacts states “there are no actions for this type”.

Do you have XMPP installed and prosody?

XMPP is installed and Prosody is running. In fact a third party XMPP client (Psi+) does successfully connect to the XMPP server on the FreePBX.

I would also add the presence does successfully pass between all three pieces: iSymphony V3, UCP, and Psi+.


Did you managed to solve your issue? I’m having the same issue as well.

I hate to pull up an old thread, but I am wondering as well if you got this working?

I also have everything working (clean install from the latest Distro - version 10.13.66 with asterisk 11) and I am unable to get the XMPP chat icon to appear in the UCP - no matter which browser I use. I have got the WebRTC phone working with no problems… Presence syncs correctly, but I am just not able to get the chat icon to appear.

I have all my users enabled for XMPP etc… Nodejs is running, XMPP license is applied, I see no errors in the httpd logs. I am at a loss as to where to turn from here!

Regretfully, no I never did get it working. I just have not been able to put in the time to troubleshoot in the last six months or so. I do hope to revisit this when things settle down though.

If you’re running FreePBX 13, upgrade to the latest versions of the following:
ucpnode v13.0.24 & ucp v13.0.29 & xmpp v13.0.8

You may need to be on edge to get them. Once upgraded, set your user and group permissions for xmpp again in User Manager and you should be good to go.

1 Like

Perfect! updating the modules fixed it. This was driving me nuts!

Thanks for letting me know. I did have to enable edge modules before those updates came though.

1 Like