Two PBXs on same network

I am in the process of putting the PBX on a new computer. I decided to manually set up the new Freepbx server since the computer is a 64 bit vs the old 32 bit, and I want to refresh my setup skills. I transferred the registration to the new pbx, and plan to set it up at leisure leaving the old, now unregistered pbx, run the POT lines, and leave the business running smoothly, since they can manage without the voip lines.
My problem is that I cannot run both pbxs on the same subnet even though they have different IP addresses. When I turn the new pbx on the old one quits interacting with the phones, generally becomes unusable, even though it shows no error on the web interface or the phones. The pbxs have different IP addresses.
Any thoughts or ideas.

You can have multiple PBX servers on the same subnet.

Depends how your phones are configured, DNS, Network etc.

You will need to tell us more about your setup

All the IPs are DHCP including cell phones with their voip apps. I not care if the cells phones don’t work during the setup time.
What would you like to know?

DNS is the gateway and alt. DNS is

DHCP isn’t magic. You’ll need to set up each “class” of device with the options specific to that class. In addition, you should set the servers up in DHCP so that they get “effectively static” IP addresses.

The tricky bit is if you have incoming traffic from the outside intended for both PBXs. This can present several challenges, especially since FreePBX and Asterisk are notoriously hard to set up as “multi-tenant” solutions.

Tell us more about the actual set up of your network. We can’t read the DHCP config files, so saying “DHCP is handling everything” is telling us nothing.

I did find a network problem, after which I fixed it worked alright. It was a stupid problem - pointed to the wrong router!
But I have a continuing problem. The new pbx and the old one act the same - voip calls through sipstation go through as they should, and calls come in as they should. But there is no sound. Looks like a firewall problem. But I have port 5060 forwarded to the pbx, as well as 10000-20000. Outgoing is not restricted. The pbx says the connection is fine. Is there any way to check what is going on?

To the old or new? :wink:

To the new. I checked that again.

The old is now stand alone working with land line telephones lines only.

I should say what the problem was. We have changed Internet providers, and apparently Sipstation did not recognize the new IP number and put a block on. Was quite a challenge to get to the root of it!