Turn off forced firmware update


(Jeremy Schaeffer) #1

I have a situation where I need to update the firmware on phones, but I cannot use the automated firmware update in endpoint. What I want to do is turn off, or set to none, the forced firmware version then update the phones one at a time then I can set it to the new firmware. Reason for this is the Sangoma firmware of 2.0.4.59 has a bug in it where if you try to update the firmware over wifi on the S705 it goes into a lockout loop. It was fixed in later versions, but if you try to change it to anything other than .59 it bricks the phone. Rather difficult to deal with. To change it you have to do the upgrade manually over the phone gui, but then when it reboots it must have the new firmware in the template, or it just reverts back. I have 30 some phones to do, If I set the template to the new phones, within a short time they figure it out and try to install the new version and it bricks the phone. What I need to do is set the template to not check for new firmware so I can update the phones one at a time then set the template to the new version once they are all updated. Any suggestions? Thanks!


(Cyberdocwi) #2

Hello.
I have a similar situation, where I need to test out a different firmware on Sangoma phones, and like you, my local beta firmware is being overwritten by the boot process, and the phone is bringing down the production firmware, overwriting my efforts. I have the production firmware in slot 1, and nothing in slot 2. The Firmware management for the template will not let me select the the empty slot 2.
I even tried to create a duplicate template, in hopes that the firmware management would be undefined. Nope same issue.
Unlike your case, I do have operational telephones on this production system, so I do not wish to get wild with testing various iterations here.

I am going to build a test system to figure out how to solve this.

!! WARNING !!
One wild suggestion, if you are comfortable with Linux, is to take out the /tftpboot directory, where the firmware is stored. IF your system doesn’t have any firmware available, then it won’t be able to send it to your phones. I have done this long ago, with FreePBX before the Extension Manager was around (Aastra phones, last decade), and you do risk other damage if you perform this step.

I would test clobbering /tftpboot on a test system, with a good backup using TAR or perhaps copy the data structure somewhere else, perhaps /root/tftpboot, so that you may restore it down the road.

I too would like to see at the template level a master switch to make firmware unavailable.

Christian


(Lorne Gaetz) #3

Populate slot 2 with bundle 0.00


(Jeremy Schaeffer) #4

I was wondering about version 0.00, I will have to try that. I thought about deleting the firmware, I have done manual updates by changing it myself, but I guess I have not tried just deleting the firmware directory. I guess I can set it to 0.00 and see if the files go away.


(Jeremy Schaeffer) #5

Yep, that should work. 0.00 empties the folder to no firmware, so that should do it. Thanks!


(Lorne Gaetz) #6

The 0.00 bundle is intended to be used when installing your own custom firmware:
https://wiki.freepbx.org/display/FPG/EPM-Admin+User+Guide#EPM-AdminUserGuide-InstallingCustomFirmware


(Cyberdocwi) #7

Hello.
Just writing that the 0.00 firmware process worked for me. Thank you! I prefer doing that over clobbering /tftpboot

Christian