Trying to use sipml5 but getting AVPF is not enabled error


I’m trying to make work but when I’m calling a number I’m getting the following error:

[2013-09-06 02:10:55] WARNING[11685][C-00000003] chan_sip.c: Received SAVPF profle in audio offer but AVPF is not enabled: audio 58191 RTP/SAVPF 111 103 104 0 8 107 106 105 13 126
[2013-09-06 02:10:55] WARNING[11685][C-00000003] chan_sip.c: Insufficient information in SDP (c=)…

My google-fu failed, so any help will be appreciated.


thanks, but where do I enter these settings in freepbx?

You can’t you, will have to roll up your sleeves and get your hands dirty :wink:

thanks, any chance can you direct me to what to look up on google? I think these can be entered in custom.conf files, right?

It’s not that easy, if you read my link fully, you will find that there are quite a few requisites that are not built into most FreePBX distros, you will need to recompile Asterisk after satisfying all those requisites and their prerequisites. The tool chain necessary will also have to be constructed, none of this is generally available prepackaged Asterisk/FreePBX distro.

If you want to go that route , I suggest you build a raw asterisk box on the OS of your choice (mine is Debian), iterate through

make menuselect
make install
make samples

until the build is clean and functional, generate the necessary certificates backed by a “trusted” authority.

Only then even think about overlaying FreePBX to manage your shiny new websocket enabled Asterisk.

WebRTC in Asterisk is bleeding edge at best. The spec for ml5 is not fully developed therefore (this is straight from digums’ mouths) WebRTC in asterisk is not stable and can’t be fully relied upon (things could change/break). Once things setting down then we will come out with a module to help with this.