Trying to setup webrtc phone


#1

I’m following the wiki:
https://wiki.freepbx.org/display/FPG/WebRTC+Phone-UCP#WebRTCPhone-UCP-EnablingWebRTC
I suppose the default self-signed certificate doesn’t work , should I create anyway a new LE one ?
Is a valid recognized certificate required for use of WEBRTC Phone inside a LAN also ?


(Andrew) #2

AFAIK you still need a cert from a valid CA in order to get a WebRTC phone to work with UCP, regardless of where you are connecting from.


(Lorne Gaetz) #3

A secure TLS cert is required by the browser before it will allow access to the microphone. All modern browsers enforce this.


#4

Anyway I still can’t see any “Enable WebRTC Phone” option into User Management…
there is a wiki note: “If you do not see the WebRTC options you missed a step above.”
Is it because of no certificate installed yet ?
Or some other issue ?


(Andrew) #5

You should definitely complete all of the required steps before trying to enable it.


#6

Well, LE certificate is installed and imported by Apache now.
I still don’t see any WebRTC icon in UCP or WebRTC settings in User Management neither…
Am I missing something ?
Should I use GUI in HTTPS mode ?


(Andrew) #7

Is certificate manager aware of the cert? It needs to be aware of the certificate and set as the default.


#8

Yes it is aware, I got it working after a reboot.
And…webrtc icon is not right availabe at ucp dashboard, one have to add it as sidebar widget.
Wiki should be updated a little …

Thank you


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.