Trying to Restore to New VM


(Cj) #1

Hi all

I have a client with a FreePBX system - Originally the VM was inside a Xen Server which failed. I managed to pull a config backup (.tgz file) from the web interface of FreePBX - The backup size is around 500MB.
Im trying to restore to a freshly loaded FreePBX VM inside HyperV - I go to the Backup/Restore page - upload the config file to restore and then nothing happens it just takes me back to the Restore page.

Rather concerning, am I trying to restore wrong? The version matches the old VM which is now dead.

I tried an image with Acronis and Clonezilla but the VM doesnt boot, I do have an .xva file which I managed to export from Xen server, but I need to get that into HyperV (Somehow).

Any help greatly appreciated.
Thanks


(Lorne Gaetz) #2

(Cj) #3

Ill try that right now!

Thank you.


(Cj) #4

Invalid backup for or undefined error

Arrrrgggghhhhhh


(Itzik) #5

What did you try?

Also, are you restoring on the same version of FreePBX?


(Cj) #6

I imported my Backup from the old FreePBX VM - Yep exactly the same version - have buiklt a fresh FreePBX VM with the same versions of FreePBX as the old one.

Old one was 14.0.3.4 which this one is too.

I simply went to retore, and did as suggested above - ran an initial full backup - transferred the tgz from old backup and hit restore when the above Error occurs.


#7

We’ve done quite a few of these restores and always have to CHMOD the backup file to 777. We also always run a local backup of the new system first so the Default_backup folder is created, and then place the file from which we are restoring there (then CHMOD to 777).

So:

  1. Create new VM.
  2. Update.
  3. Run local backup in new VM.
  4. WinSCP backup file to /var/spool/asterisk/backup/Default_backup
  5. CHMOD backup file to 777
  6. Run local restore, selecting the correct backup file.

(Itzik) #8

Run backup on the new VM, then copy the old backup file with WinSCP to/var/spool/asterisk/backup/your_backup_name run fwconsole reload.

Then go to the GUI and browse to that file and hit restore


(Cj) #9

Thanks all.

Tried all of your suggestions but it still gives me the same error.

Interestingly, my backup is the above one - which shows nothing to the right but the second backup (the default one for this install) shows the info to the right so Im guessing I have a corrupt backup!

I could cry, but maybe time to redo the whole system which is not very good really and not very reliable!

Thanks


(Itzik) #10

Sorry I missed it.
What happens when you try to restore that backup?


(Cj) #11

If I upload the backup file through the web GUI it uploads and then nothing happens I get redirected to the Restore screen, if I SCP the file over to the default backup directory, then go into the GUI and browse in Default location the tgz backup file shows up bit when I click restore I get an error saying error or undefined.

I’m am literally at a loss, I have a 500mb backup file which won’t restore even though it is supposed to


(Itzik) #12

Is the backup module, and framework up to date?


(Cj) #13

I’ve ran every update I can in the GUI and via yum update.

:frowning:


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.