Trying to get Cisco 7942g on FreePBX

I’ve been trying to get a 7942g working with FreePBX for what seems like months. I have tried different firmware versions, using different SEP(MAC) templates, trying different websites for instructions for the config file, different options in the TFTP software on my PC, and it still won’t.

I have also tried sip debugging in the Asterisk CLI: “asterisk -vvvvvr”, and sometimes it gives me a yellow NOTICE tag and says it’s trying to register from my servers IP to the Phones IP but can’t because “wrong password”. The secret in the Cisco’s config file matches the one for the extenion(s). The phone just gets stuck on “registering” for a few minutes but won’t actually do anything and the line keys have a little x next to the phone icon plus no dial tone.

I’ve tried both SIP[chan_pjsip] and SIP(Legacy) [chan_sip] .

When I factory reset the phone and plug the phone and server into a switch without the actual network(router cable) connected, the phone will boot and the files go through to the phone successfully. Then when it gets to “registering” I unplug the server from the switch+relocate the switch and phone and plug in the actual network cable to give the phone internet. Won’t register. I’ve also tried restarting the phone with the actual network cable originally plugged in and without the server plugged in, won’t register. Should I have the server connected to the actual network too?

I’m quite frustrated and don’t know what else could be going wrong. This is from one of my old threads that never received an answer, so i’m asking again.

Those phones must use a very short password, I think no longer than 8 characters.

1 Like

I tried a short password both in FreePBX and the config file for the Cisco phone. It still just gets stuck on registering.

Post your actual logs and SIP traces. Also you can download very detailed logs from the phone itself. These will all help you come to a solution.

How do I do any of that?

Asterisk logs are in /var/log/asterisk/full

SIP traces are enabled at the Asterisk console by typing pjsip set logger on (or off when you are done) or sip set debug on if you are using chan_sip.

Phone logs are available by browsing to the IP address of your phone and clicking Console Logs and then downloading the logXX.log files you see there.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.