Trying first install to Ubuntu Server 12.04 - fatal: Not a git repository (or any of the parent directories): .git

Using the wiki article, Installing FreePBX on Ubuntu 12.04 Server (Precise Pangolin) I get the following:

# export VER_FREEPBX=2.11.0
# cd /usr/src
# git clone freepbx
fatal: Not a git repository (or any of the parent directories): .git

I also tried changing export VER_FREEPBX=2.11.0 to export VER_FREEPBX=2.11 and export VER_FREEPBX=2.11.25 and neither changed anything

Any help appreciated.

I just ran

git clone freepbx

I get

Initialized empty Git repository in /root/freepbx/.git/
remote: Counting objects: 31509, done.
remote: Compressing objects: 100% (12453/12453), done.
remote: Total 31509 (delta 23256), reused 24685 (delta 18560)
Receiving objects: 100% (31509/31509), 34.35 MiB | 1.11 MiB/s, done.
Resolving deltas: 100% (23256/23256), done.

Do you have DNS setup correctly?

1 Like

Strange - I had shut that server down, then booted it back up after seeing your response, and now it works! DNS on the server is default managed by dhclient(?) vanilla Ubuntu install - I’ve never even looked at it (as in ever). The gateway is a pfSense box, which also acts as local DNS server and been running since 2.1.4 update last week. This is my test rig, so the only packages installed are those required by the tutorial and Ubuntu updates.

Also: I was able to use git checkout release/${VER_FREEPBX} only after running export VER_FREEPBX=2.11, which is different from the wiki suggested export VER_FREEPBX=2.11.0.

The wiki has an error but it doesn’t matter as master and release/2.11 track each other