Trunks Not Stable? Asterisk issue?

Normally I would post in the Users section but I am thinking this might be a bug. I am sure sure, if I was I would post it in the tracker.

Anyhow I have several trunks. and I might be dropping the first and the last trunk. Anyway I wrote a script that would login to the server asterisk -r and the get sip registry and email me if the text matched “in state Request” And ever since I have been checking I have been astounded at how often this happens.

Now it isnt a problem with the script as when I check in freepbx it shows 0 trunks registered.

I dont think it is my providers as it happens to differnet provers at differnet times.

Asterisk is the only used app on the machine. Little cpu usage. Static IP. Firewall disabled for a bit. ISP is FIOS and the connection is pretty solid. Just to be sure I am running a smokeping. I will also try some other line monitoring tools.

It is me or is it Asterisk?

Verizon FIOS by chance? I ran PingPlotter against a Verizon FIOS the other day and watched various hops change routes… a lot.

I can’t remember if smokeping reports all the hops?

Cacti can graphically map your trunk availability.

Engineer Tim put together a nice RP/M

For you of CentOS ilk =

cd /usr/src
mkdir cacti
cd cacti
yum install net-snmp-utils
rpm -ivh et-cacti-trixbox-0.0.1-2.noarch.rpm
rm et-cacti-trixbox-0.0.1-2.noarch.rpm

Simply navifate to myipaddress/cacti

username: maint password: password

This is my smokeping so far…

What other online tests would you suggest?

Thank you . Working on it.

Got to yum install net-snmp-utils fine

[email protected] [/usr/src/cacti]# rpm -ivh et-cacti-trixbox-0.0.1-2.noarch.rpm
error: Failed dependencies:
rrdtool is needed by et-cacti-trixbox-0.0.1-2.noarch
[email protected] [/usr/src/cacti]#
[email protected] [/usr/src/cacti]# yum install et-cacti-trixbox-0.0.1-2.noarch
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Parsing package install arguments
No Match for argument: et-cacti-trixbox-0.0.1-2.noarch
Nothing to do

Yes, localinstall expects to find an rpm on your local harddrive. You would need to cd to the /usr/src/cacti directory where you downloaded the rpm to before running it. (/usr/local/src might be a better location for this type of thing by the way) If the rpm has dependancies that are not installed yum will go look for them in whatever repositories you have defined.

Which brings us to the next problem. If the repositories don’t contain rrdtool then yum won’t be able to resolve the dependancies for you. I looked through the history here and didn’t see any mention of what distribution you are using. Running yum install rrdtool* on my fedora machine produces the following list:

rrdtool i386 1.3.8-1.fc10 updates 397 k
rrdtool-devel i386 1.3.8-1.fc10 updates 27 k
rrdtool-doc i386 1.3.8-1.fc10 updates 237 k
rrdtool-perl i386 1.3.8-1.fc10 updates 39 k
rrdtool-php i386 1.3.8-1.fc10 updates 24 k
rrdtool-python i386 1.3.8-1.fc10 updates 27 k
rrdtool-ruby i386 1.3.8-1.fc10 updates 17 k
rrdtool-tcl i386 1.3.8-1.fc10 updates 20 k
Installing for dependencies:
dejavu-lgc-fonts noarch 2.26-2.fc10 fedora 3.5 M
ruby-libs i386 fedora 1.7 M

What distro are you using?

Try yum localinstall et-cacti-trixbox-0.0.1-2.noarch.rpm

yum install rrdtool* then install the rpm again

I think that if I ran
yum localinstall et-cacti-trixbox-0.0.1-2.noarch.rpm

That would mean I would have to download it to a local folder correct?

Setting up Local Package Process
Cannot open file: et-cacti-trixbox-0.0.1-2.noarch.rpm. Skipping.
Nothing to do

[~]# yum install rrdtool*
Setting up Install Process
Setting up repositories
update 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Parsing package install arguments
No Match for argument: rrdtool*
Nothing to do