Trunks not showing up/registering

I am moving from an old Trixbox system to an up to date system on new hardware. I am able to make calls between extensions but not to an outside line or receive a call from an outside line. The dashboard shows my online/offline users, 0 active calls but not even showing either of the trunks as being online (or offline for that matter). I havent been able to find anything in the log to explain why neither of my trunks is trying to connect and they are both Enabled and included in the outbound route.

Freepbx 13.0.190.7
Asterisk 13.7.0

To give you an idea how little information you provided, here is the “First set” of questions to help us help you. Note that, depending on the answers from these questions, there might be two or three more sets of questions like this:

  • How are the outbound calls failing?
  • Can you see (in the logs) where they are not making the connection?
  • Have you tried using “tcpdump” to make sure the firewall setup in both the integrated and external firewalls are the same?
  • Are you behind a NAT router?
  • Are you on the same machine as your old TrixBox, or are you connected to a new machine?
  • Are you using the same IP address as before?
  • How does your carrier expect you to connect (IP address or username/password)?
  • Have you double-checked the registration options?
  • Are you trying to connect with Chan-SIP, or PJ-SIP?
  • Have you restarted the server (hardware reset) or just used fwconsole?
  • Have you checked the logs to see if your registration is succeeding or failing?

Edit: I had this all written up a week ago and thought it had been posted but just took a look and found it unposted. Sorry for taking so long.

Its hard knowing what information is relevant without asking the first question.

  • How are the outbound calls failing? I get an “All circuits are busy now” message.
  • In case it helps, incoming calls get a “The person you are trying to reach is not accepting calls at this time, please try again later”. Message 24.
  • Can you see (in the logs) where they are not making the connection? The only log lines I can find that include the trunk names are:
    [2017-01-17 08:17:18] VERBOSE[2618][C-00000000] pbx.c: Executing [[email protected]:14] Set(“PJSIP/26-00000000”, “custom=SIP/VP-SIPJFKA”) in new stack
    [2017-01-17 08:17:18] VERBOSE[2618][C-00000000] pbx.c: Executing [[email protected]:23] Dial(“PJSIP/26-00000000”, “SIP/VP-SIPJFKA/+14019324294,300,”) in new stack
  • Have you tried using “tcpdump” to make sure the firewall setup in both the integrated and external firewalls are the same? The integrated firewall is turned off.
  • Are you behind a NAT router? It is behind a sonicwall which is nat’d
  • Are you on the same machine as your old TrixBox, or are you connected to a new machine? They are different hardware.
  • Are you using the same IP address as before? The same IP is in use on both, so I have to turn one off before turning the other one on.
  • How does your carrier expect you to connect (IP address or username/password)? Username/password which were copied fro the original server
  • Have you double-checked the registration options? I copied the options from the registration string from one to the other.
  • Are you trying to connect with Chan-SIP, or PJ-SIP? I am using PJ-SIP on the new server but was using Chan-SIP on the old server.
  • Have you restarted the server (hardware reset) or just used fwconsole? The server has been restarted many times throughout.
  • Have you checked the logs to see if your registration is succeeding or failing? I cant find anything in the logs about the trunk trying to register. The dashboard statistics graphic doesnt even show the trunks.

Hopefully this will get you to the next series of questions.

Here you go:

  • How do you flush the ARP cache on the Sonic Wall when you switch machines?

  • If you are getting an answer like “The extension you dialed is busy” then you are making it onto one of the servers. Are the phones registered with the old server, or the new one? How are you clearing the phones’ ARP caches.[quote=“Ryland, post:3, topic:39029”]
    [2017-01-17 08:17:18] VERBOSE[2618][C-00000000] pbx.c: Executing [[email protected]:23] Dial(“PJSIP/26-00000000”, “SIP/VP-SIPJFKA/+14019324294,300,”) in new stack
    [/quote]

  • Are you sure your provider is expecting the outbound phone number to be formatted with a + and 1 on the front? It’s really unusual for a VOIP provider to be willing to accept that, let alone require it.

I think you are experiencing a problem with your outbound trunk. If you are using PJ-SIP, you will have to set up a different inbound port for Chan-SIP. Also, are you sure your provider is will to accept connections from a PJ-SIP handler?

The more we talk, the more it sounds like your outbound trunk is broken. I’d recommend setting up your servers with different addresses so you can control what the connections look like without having to clear the system-wide ARP cache for every connection in your LAN.

I was able to fix this by changing Channel Driver from chan_pjsip to both then rebooting. Ive tested calls from outside to inside and including remote locations and everything seems fine now.

Thanks.