Trunks not registering


(Arjones5) #1

I have an active ticket with SIPStation for this issue but I’m desperate and we’re not making any headway. I was getting service issues where the trunk would just throw me a SIP Ping Unreachable error, now it is constantly not able to register the trunk. The DNS request is making it out, my ISP isn’t blocking the protocol, I just can’t seem to get any traction on the issue - let along determining what the root cause it.

[2019-10-02 14:49:00] NOTICE[1362] chan_sip.c: – Registration for ‘[user]@trunk1.freepbx.com’ timed out, trying again (Attempt #20)
[2019-10-02 14:49:01] NOTICE[1362] chan_sip.c: – Registration for ‘[user]@trunk2.freepbx.com’ timed out, trying again (Attempt #20)


(Dave Burgess) #2

Log into the console and run a ‘traceroute trunk1.freepbx.com’. This will give you an idea of where the bottleneck is as well as giving you a positive indicator that your DNS is working.

What DNS servers are you using?
Can you connect if you remove DNS from the process (and use just an IP Address)?


(Arjones5) #3

The traceroute takes me all the way back to the SIPStation server IP:
static.192.159.66.3.cyberlynk.net (192.159.66.3) 33.483 ms 33.383 ms 33.446 ms

I use OpenDNS/Umbrella for the DNS and show that is successfully resolved the domain. I will give the IP a shot to see if it changes things up.


(Arjones5) #4

No dice on the IP…
[2019-10-02 15:53:11] NOTICE[1362] chan_sip.c: – Registration for ‘[user]@192.159.66.3’ timed out, trying again (Attempt #2)


#5

I’m not a SIPStation user, but was able to probe 192.159.66.3 UDP port 5060 and get a response.

So, possibilities include:

  1. Inadvertently blocked by FreePBX firewall. Try a test with it disabled, or use tcpdump to check.

  2. Problem with request or parsing response. At the Asterisk command prompt, type sip set debug on and look at the request going out and the response, if any.

  3. Problem with your router/firewall or other networking gear between PBX and the internet. Try rebooting modem and router.

  4. If running virtual, problem with VM networking or firewall setup.

If you have any other networking complexity (VLANs, VPN, multiple NICs, etc.), please post details.


(Arjones5) #6

Here’s the plot twist, they implemented a RasPBX so the Asterisk command prompt and the firewall aren’t existent. I’m thinking of scrapping what they had on the Raspberry Pi and reinstalling a full FreePBX on the Pi. I’m honestly shocked at how well this thing performs considering…

I’m doing this as a friend that owns a small company because some toddler set up the system and then moved. According to them, it worked for a while and then went belly up.


#7

You might have the only system with this combination:

SIPStation: Quite expensive, but top class quality, reliability and support.
RasPBX: About as cheap as you can get.

However, you should be able to ssh into the Pi, get a root shell prompt, run
asterisk -r
and then type
sip set debug on
and wait for the registration to be retried; you should see REGISTER going out and possibly a response coming back. The SIP trace will appear both on the console and in the regular Asterisk log.

Please describe the network. Have you tried rebooting modem, router and the Pi?


(Arjones5) #8

I really don’t disagree at all - I would have never done it this way. I’ve rebooted everything multiple times to no avail. I’ll try the sip debug when I get onsite. Right now the failover is going to a google number and ringing their cells so the workaround is working as expected.

Do we know if it’s possible to do a full FreePBX install on a Pi versus a RasPBX?


#9

A Pi cannot run the FreePBX Distro, nor is there any way to run commercial modules on it. However, you can otherwise build and run complete systems – see https://www.dslreports.com/forum/r30661088-PBX-FreePBX-for-the-Raspberry-Pi .

However, based on what we know so far, you have a simple networking problem that shouldn’t be hard to fix; there is no reason to start over. Since you have shell access, you can run the SIP debug remotely.

If you do need to start over, you might consider running in the cloud. For very small businesses, this is usually more robust. It won’t be knocked out by a power or internet outage and recovery from hardware or software failures is much easier. Options include ready-to-go systems such as https://www.freepbxhosting.com/ or http://www.rentpbx.com/ , installing on commodity cloud providers (Vultr, RamNode, etc.) or installing from scratch on Amazon, Google or other major clouds.

For on-site, consider running in a virtual machine on hardware that is already deployed for other applications. Or, run on a mini PC such as https://www.amazon.com/ADLOKO-Z83-Pro-x5-Z8350-Processor-1000Mbps/dp/B07Q8KK7NT , which is standard Intel architecture and should be able to run the Distro ISO without modification.


#10

In Settings -> Asterisk SIP Settings, General tab, confirm that External Address has your correct IPv4 public address and that Local Networks is set correctly (probably 10.0.0.0 / 8).

On the Chan SIP Settings tab, confirm that IP Configuration is properly set for Static or Dynamic (and if dynamic, that DDNS is properly set up).

If you change any of the above, restart (not just reload) Asterisk, or reboot the whole server.

If you have a dynamic IP but DDNS was never set up, for this test pretend it is static and fill in (if the Detect Network Settings button doesn’t do it automatically) the current public IP.

If you changed the above settings but it didn’t help, post a new log with SIP trace.


(Arjones5) #11

Welp. I went to the extreme. I wiped the edge router config and BAM - they register right off the bat.

Luckily, there weren’t many deltas between the backup and factory so we’ll see what starts fighting me. They also told me that the VPN service stopped at the same time so I’m wondering if they don’t just need a new router all together.


(Arjones5) #12

Following back up on this. Evidently Netgear released a firmware update that caused issues in many of their devices causing wireless instability and…wait for it…randomly dropped packets. I have convinced them to upgrade their equipment to actual commercial-grade network equipment and dedicate a FreePBX appliance. All is well thus far.