Trunk stops working after PBX IP address change

I just upgraded routers recently and changed the PBX’s IP address from to I did this with these instructions

The PBX was once on the old router. It was the only thing plugged into that router. Everything else, phones and trunk were plugged into the newer router, and it all worked.

After I changed the IP address of the PBX, and moved it to the new router. I updated the IP’s on the phones and the Cisco SPA3000. Everything still works, except for incoming calls. The SPA3000 lines are both registered. When you dial in, the SPA3000 answers, but does no proceed the PBX. The SPA3000 only presents the caller with a few clicks before hanging up after 17 seconds.

Did you add new ip range to asterisk Sip settings and to firewall?


Show us the config settings on the SPA3000 - gonna bet you missed an IP Address setting in there.

1 Like

i’m going to try a fresh install later

I just changed my router’s address and forgot to change the sip Nat setting as mentioned above. It’s the classic 20 sec hangup. Changed my network IP in sit Nat settings and I was good to go again.

Where would I change this?
I have host=dynamic

Go to the FreePBX GUI
Asterisk SIP Settings
NAT Settings
Click Detect Network Settings
New (correct) Local Networks setting is then updated to current.
Submit, Update to save settings.

Its not a SIP trunk setting that I mention, but a general SIP NAT setting for your LAN.
In my situation, the above steps autodetected and reset the LAN NAT IP from to my new local LAN address of (I had some address conflicts with my backup router and had to make the change.)
20 second call drops immediately stopped and system behaved properly as it used to.

I know this is a terrible solution, But I was able to fix this after preforming a clean installation. My PSTN line would just refuse to register with the old install. Not sure why, but the reinstall gave me no issues

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.